]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/databases/mariadb_replication.nix
Add mysql and redis monitoring
[perso/Immae/Config/Nix.git] / modules / private / databases / mariadb_replication.nix
index 5f97e84aa4bea632dbe7b6b944ef618741c5b15f..52a34d3e20d9fc91671f7e7b766f93bce205f385 100644 (file)
@@ -114,6 +114,17 @@ in
           password = ${hcfg.dumpPassword}
         '';
       }
+      {
+        dest = "mysql_replication/${name}/client";
+        permissions = "0400";
+        user = "mysql";
+        group = "mysql";
+        text = ''
+          [client]
+          user = ${hcfg.dumpUser}
+          password = ${hcfg.dumpPassword}
+        '';
+      }
     ]) cfg.hosts);
 
     services.cron = {