]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/databases/default.nix
Add mysql replication
[perso/Immae/Config/Nix.git] / modules / private / databases / default.nix
index b2739bfbc4784aaa0e0e119d8b9565d862ccdf08..73714107ff519ee70d82e3752f033e63429fb0a4 100644 (file)
@@ -21,6 +21,10 @@ in
         inherit (myconfig.env.ldap) host base;
         inherit (myconfig.env.databases.mysql.pam) dn filter password;
       };
+      replicationLdapConfig = {
+        inherit (myconfig.env.ldap) host base;
+        inherit (myconfig.env.ldap.eldiron) dn password;
+      };
       credentials.root = myconfig.env.databases.mysql.systemUsers.root;
     };
 
@@ -38,8 +42,8 @@ in
         inherit (myconfig.env.databases.postgresql.pam) dn filter password;
       };
       replicationLdapConfig = {
-        inherit (myconfig.env.ldap) host base password;
-        dn = myconfig.env.ldap.host_dn;
+        inherit (myconfig.env.ldap) host base;
+        inherit (myconfig.env.ldap.eldiron) dn password;
       };
       authorizedHosts = {
         immaeEu = [{