]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/databases/default.nix
Refactor secrets handling
[perso/Immae/Config/Nix.git] / modules / private / databases / default.nix
index 27b0ba8a388322d3ffaf56753f061974b1e4c593..1241658a18574846a057ca06b68d444a42db25f3 100644 (file)
@@ -10,10 +10,6 @@ in
     };
   };
 
-  config.nixpkgs.overlays = lib.mkIf cfg.enable [ (self: super: {
-    postgresql = self.postgresql_11_custom;
-  }) ];
-
   config.myServices.databases = lib.mkIf cfg.enable {
     mariadb = {
       enable = true;
@@ -29,7 +25,7 @@ in
     };
 
     openldap = {
-      accessFile = "${config.myEnv.privateFiles}/ldap.conf";
+      accessFile = ../../../nixops/secrets/ldap.conf;
       baseDn = config.myEnv.ldap.base;
       rootDn = config.myEnv.ldap.root_dn;
       rootPw = config.myEnv.ldap.root_pw;
@@ -46,12 +42,6 @@ in
         inherit (config.myEnv.servers.eldiron.ldap) dn password;
       };
       authorizedHosts = {
-        immaeEu = [{
-          ip4 = [
-            config.myEnv.servers.immaeEu.ips.main.ip4
-            config.myEnv.servers.immaeEu.ips.alt.ip4
-          ];
-        }];
       };
       replicationHosts = {
         backup-2 = {