]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/opendmarc.nix
Upgrade to nixos-unstable
[perso/Immae/Config/Nix.git] / modules / opendmarc.nix
index e18ec82a66ef466a30e3d0e80b100876a7b8809b..6137d100d68d95ffa4f589ff11a53f592379251f 100644 (file)
@@ -59,16 +59,18 @@ in {
 
   config = mkIf cfg.enable {
 
-    users.users = optionalAttrs (cfg.user == "opendmarc") (singleton
-      { name = "opendmarc";
+    users.users = optionalAttrs (cfg.user == "opendmarc") {
+      opendmarc = {
         group = cfg.group;
         uid = config.ids.uids.opendmarc;
-      });
+      };
+    };
 
-    users.groups = optionalAttrs (cfg.group == "opendmarc") (singleton
-      { name = "opendmarc";
+    users.groups = optionalAttrs (cfg.group == "opendmarc") {
+      opendmarc = {
         gid = config.ids.gids.opendmarc;
-      });
+      };
+    };
 
     environment.systemPackages = [ pkgs.opendmarc ];