]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - libs.nix
Improve iota cli app build
[perso/Immae/Config/Nix.git] / libs.nix
index ad517f283242a4d6faf1c666339ebcb125b8d994..a9e1e78f01d4f74bd9e177299ea5a3b1d5ed322d 100644 (file)
--- a/libs.nix
+++ b/libs.nix
@@ -1,14 +1,6 @@
-let nixpkgs_unstable = import (builtins.fetchTarball {
-  # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
-  # versions
-  name = "nixos-unstable-2018-12-08";
-  url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
-  sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
-}) {};
-in
-  with nixpkgs_unstable;
-{
-  inherit nixpkgs_unstable;
+{ nixpkgs }:
+with nixpkgs;
+rec {
   fetchedGithub = path:
     let
       json = lib.importJSON path;
@@ -36,8 +28,6 @@ in
       src = fetchgitPrivate json.git;
     };
 
-  checkEnv = var: builtins.stringLength (builtins.getEnv var) > 0;
-
   wrap = { paths ? [], vars ? {}, file ? null, script ? null, name ? "wrap" }:
     assert file != null || script != null ||
       abort "wrap needs 'file' or 'script' argument";
@@ -55,4 +45,6 @@ in
       ''
         makeWrapper "$f" "$out" ${toString args}
       '';
+
+  yarn2nixPackage = callPackage (fetchedGithub ./fetched/yarn2nix.json).src {};
 }