]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - libs.nix
Adapt postgresql overlay
[perso/Immae/Config/Nix.git] / libs.nix
index ad517f283242a4d6faf1c666339ebcb125b8d994..981039ec2d1b354e43da3fca3d6f9ce349f44f9b 100644 (file)
--- a/libs.nix
+++ b/libs.nix
@@ -1,14 +1,17 @@
-let nixpkgs_unstable = import (builtins.fetchTarball {
-  # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
-  # versions
-  name = "nixos-unstable-2018-12-08";
-  url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
-  sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
-}) {};
-in
-  with nixpkgs_unstable;
-{
-  inherit nixpkgs_unstable;
+{ nixpkgs }:
+with nixpkgs;
+rec {
+  yarn2nixPackage = let
+    src = fetchFromGitHub {
+      owner = "moretea";
+      repo = "yarn2nix";
+      rev = "780e33a07fd821e09ab5b05223ddb4ca15ac663f";
+      sha256 = "1f83cr9qgk95g3571ps644rvgfzv2i4i7532q8pg405s4q5ada3h";
+      fetchSubmodules = true;
+    };
+  in
+    (callPackage src {}) // { inherit src; };
+
   fetchedGithub = path:
     let
       json = lib.importJSON path;
@@ -36,8 +39,6 @@ in
       src = fetchgitPrivate json.git;
     };
 
-  checkEnv = var: builtins.stringLength (builtins.getEnv var) > 0;
-
   wrap = { paths ? [], vars ? {}, file ? null, script ? null, name ? "wrap" }:
     assert file != null || script != null ||
       abort "wrap needs 'file' or 'script' argument";
@@ -55,4 +56,5 @@ in
       ''
         makeWrapper "$f" "$out" ${toString args}
       '';
+
 }