]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - libs.nix
Make some packages compatible with no allow-import-from-derivation
[perso/Immae/Config/Nix.git] / libs.nix
index a9e1e78f01d4f74bd9e177299ea5a3b1d5ed322d..2ddfcbb59d48598cf8a82c0c8a42b3d45a0015b0 100644 (file)
--- a/libs.nix
+++ b/libs.nix
@@ -1,6 +1,17 @@
-{ nixpkgs }:
-with nixpkgs;
+{ pkgs }:
+with pkgs;
 rec {
+  yarn2nixPackage = let
+    src = builtins.fetchGit {
+      url = "git://github.com/moretea/yarn2nix.git";
+      ref = "master";
+      rev = "780e33a07fd821e09ab5b05223ddb4ca15ac663f";
+    };
+  in
+    (callPackage src {}) // { inherit src; };
+
+  nodeEnv = import ./lib/node-env.nix;
+
   fetchedGithub = path:
     let
       json = lib.importJSON path;
@@ -46,5 +57,22 @@ rec {
         makeWrapper "$f" "$out" ${toString args}
       '';
 
-  yarn2nixPackage = callPackage (fetchedGithub ./fetched/yarn2nix.json).src {};
-}
+  # This adds header colors to the builds, but it rebuilds the whole
+  # world from scratch, so only use it to debug!
+  # add it as postHook in derivations
+  immaePostHook = ''
+    header() {
+      echo -ne "\033[1;36m"
+      echo -n "$1"
+      echo -e "\033[0m"
+    }
+
+    echoCmd() {
+      printf "\033[1;34m%s:\033[0m" "$1"
+      shift
+      printf ' %q' "$@"
+      echo
+    }
+  '';
+
+} // (if builtins.pathExists ./lib/private then import ./lib/private else {})