]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - libs.nix
Add ftp.immae.eu
[perso/Immae/Config/Nix.git] / libs.nix
index ad517f283242a4d6faf1c666339ebcb125b8d994..0b5e0c1ab8bdbd41331412d768e2b466fd91ed3c 100644 (file)
--- a/libs.nix
+++ b/libs.nix
@@ -7,7 +7,7 @@ let nixpkgs_unstable = import (builtins.fetchTarball {
 }) {};
 in
   with nixpkgs_unstable;
-{
+rec {
   inherit nixpkgs_unstable;
   fetchedGithub = path:
     let
@@ -36,8 +36,6 @@ in
       src = fetchgitPrivate json.git;
     };
 
-  checkEnv = var: builtins.stringLength (builtins.getEnv var) > 0;
-
   wrap = { paths ? [], vars ? {}, file ? null, script ? null, name ? "wrap" }:
     assert file != null || script != null ||
       abort "wrap needs 'file' or 'script' argument";
@@ -55,4 +53,6 @@ in
       ''
         makeWrapper "$f" "$out" ${toString args}
       '';
+
+  yarn2nixPackage = callPackage (fetchedGithub ./fetched/yarn2nix.json).src {};
 }