]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/private/opendmarc/flake.nix
Move secrets to flakes
[perso/Immae/Config/Nix.git] / flakes / private / opendmarc / flake.nix
index debcfbda9d106cde115dcf811f771fef24c8abbe..2b73070f5df0cde63ca46aa2eaf9ddcb2acff151 100644 (file)
@@ -3,6 +3,10 @@
     path = "../../opendmarc";
     type = "path";
   };
+  inputs.secrets = {
+    path = "../../secrets";
+    type = "path";
+  };
   inputs.files-watcher = {
     path = "../../files-watcher";
     type = "path";
   inputs.nix-lib.url = "github:NixOS/nixpkgs";
 
   description = "Private configuration for opendmarc";
-  outputs = { self, nix-lib, opendmarc, my-lib, files-watcher }:
+  outputs = { self, nix-lib, opendmarc, my-lib, files-watcher, secrets }:
     let
       cfg = name': { config, lib, pkgs, name, ... }: {
         imports = [
           (my-lib.lib.withNarKey files-watcher "nixosModule")
           (my-lib.lib.withNarKey opendmarc "nixosModule")
-          #FIXME:
-          #(my-lib.lib.withNarKey secrets "nixosModule")
+          (my-lib.lib.withNarKey secrets "nixosModule")
         ];
         config = lib.mkIf (name == name') {
           users.users."${config.services.opendmarc.user}".extraGroups = [ "keys" ];