]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/peertube/flake.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / peertube / flake.nix
index 2f9c8c14f8783e36bdfe9002ebf1751f41fe6f81..e8153ebd7ab860e49f3ffbbe1ca6f7f90e6cd7f3 100644 (file)
@@ -1,9 +1,7 @@
 {
   description = "A free software to take back control of your videos";
   inputs.myuids = {
-    url = "https://git.immae.eu/perso/Immae/Config/Nix.git";
-    type = "git";
-    dir = "flakes/myuids";
+    url = "path:../myuids";
   };
   inputs.flake-utils.url = "github:numtide/flake-utils";
   inputs.nixpkgs.url = "github:NixOS/nixpkgs";
     nixosModule = { lib, pkgs, config, ... }:
       let
         name = "peertube";
-        cfg = config.services.peertube;
+        cfg = config.immaeServices.peertube;
       in
       {
-        options.services.peertube = {
+        options.immaeServices.peertube = {
           enable = lib.mkEnableOption "Enable Peertube’s service";
           user = lib.mkOption {
             type = lib.types.str;
 
             environment.NODE_CONFIG_DIR = "${cfg.dataDir}/config";
             environment.NODE_ENV = "production";
+            environment.NPM_CONFIG_LOGS_DIR = "${cfg.dataDir}/npm_logs";
+            environment.NPM_CONFIG_CACHE = "${cfg.dataDir}/npm_cache";
             environment.HOME = cfg.package;
 
             path = [ pkgs.nodejs pkgs.yarn pkgs.bashInteractive pkgs.ffmpeg pkgs.openssl ];