]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/opendmarc/flake.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / opendmarc / flake.nix
index 277fd259c8bbc39800ff09a9ee69cc349505b8f6..70b8cd7171a11069a734ecb1875e916d8a8e60fd 100644 (file)
@@ -2,9 +2,7 @@
   description = "Open source ARC implementation";
 
   inputs.myuids = {
-    url = "https://git.immae.eu/perso/Immae/Config/Nix.git";
-    type = "git";
-    dir = "flakes/myuids";
+    url = "path:../myuids";
   };
   inputs.flake-utils.url = "github:numtide/flake-utils";
   inputs.nixpkgs.url = "github:NixOS/nixpkgs";
@@ -51,7 +49,9 @@
          defaultSock = "/run/opendmarc/opendmarc.sock";
          args = [ "-f" "-l" "-p" "local:${cfg.socket}" ] ++ lib.optionals (cfg.configFile != null) [ "-c" cfg.configFile ];
        in {
-         options = {
+        # Necessary for situations where flake gets included multiple times
+        key = builtins.hashString "sha256" (builtins.path { path = self.sourceInfo.outPath; name = "source"; });
+        options = {
            services.opendmarc = {
              enable = lib.mkOption {
                type = lib.types.bool;