]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/mypackages/pkgs/webapps/yourls/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / webapps / yourls / default.nix
similarity index 63%
rename from pkgs/webapps/yourls/default.nix
rename to flakes/mypackages/pkgs/webapps/yourls/default.nix
index d940c54d1b505ebeeadb0b876c71b726775dda9d..8001a606ef94c84c52ab5625de157bd818337c94 100644 (file)
@@ -1,8 +1,8 @@
-{ yourls_config ? "/etc/yourls/config.php", mylibs, callPackage, lib, stdenv }:
+{ yourls_config ? "/etc/yourls/config.php", fetchFromGitHub, callPackage, lib, stdenv }:
 let
   pluginNames = [ "ldap" ];
   allPlugins = lib.attrsets.genAttrs pluginNames
-    (name: callPackage (./plugins + "/${name}") { inherit mylibs; });
+    (name: callPackage (./plugins + "/${name}") {});
   toPassthru = pkg: plugins: {
     inherit plugins allPlugins;
     withPlugins = withPlugins pkg;
@@ -16,7 +16,16 @@ let
         passthru = toPassthru newYourls (pkg.plugins ++ plugins);
       });
     in newYourls;
-  package = stdenv.mkDerivation (mylibs.fetchedGithub ./yourls.json // rec {
+  package = stdenv.mkDerivation (rec {
+    pname = "yourls";
+    version = "1.7.3";
+    src = fetchFromGitHub {
+      owner = "YOURLS";
+      repo = "YOURLS";
+      rev = "077018822d3594229daa8343310d0b40804b9ddc";
+      sha256 = "1av6h619rwqn0yn0kjn2s2h3gmrhmxaaa9hd5ns4ralxgg731imd";
+      fetchSubmodules = true;
+    };
     installPhase = ''
       mkdir -p $out
       cp -a */ *.php $out/