]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/mypackages/pkgs/telegramircd/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / telegramircd / default.nix
similarity index 62%
rename from pkgs/telegramircd/default.nix
rename to flakes/mypackages/pkgs/telegramircd/default.nix
index 2f1d7ca57a57e133202b3138609999fafcf95c2e..d9196a2ab944bfdb019e74b656e02ba1e05fa5a8 100644 (file)
@@ -1,11 +1,17 @@
-{ openssl, telethon, python3Packages, mylibs }:
+{ openssl, telethon, python3Packages, fetchFromGitHub }:
 with python3Packages;
 buildPythonApplication rec {
   format = "other";
   pname = "telegramircd";
   version = "master";
   propagatedBuildInputs = [ telethon aiohttp ConfigArgParse openssl ];
-  src = (mylibs.fetchedGithub ./telegramircd.json).src;
+  src = fetchFromGitHub {
+    owner = "MaskRay";
+    repo = "telegramircd";
+    rev = "40a0c7cf60492bde3f44d43f06f62e3792480139";
+    sha256 = "123fjhgxq2fzn0ar8274jv7jjbxnlpidrj5333kbch7rpcipks0y";
+    fetchSubmodules = true;
+  };
   LD_LIBRARY_PATH = "${openssl.out}/lib";
   installPhase = ''
     install -D $src/telegramircd.py $out/bin/telegramircd