]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/mypackages/pkgs/fluent-bit/default.nix
Remove manual packages for fluentd / fluentbit
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / fluent-bit / default.nix
diff --git a/flakes/mypackages/pkgs/fluent-bit/default.nix b/flakes/mypackages/pkgs/fluent-bit/default.nix
deleted file mode 100644 (file)
index 390223e..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-{ lib, stdenv, fetchFromGitHub, cmake, flex, bison, pkg-config
-, systemd, openssl, postgresql }:
-
-stdenv.mkDerivation rec {
-  pname = "fluent-bit";
-  version = "1.8.3";
-
-  src = fetchFromGitHub {
-    owner = "fluent";
-    repo = "fluent-bit";
-    rev = "v${version}";
-    sha256 = "004x135imja67babmmpkk1jpp5xwhfa8cwg1svaas2asq6cnv77d";
-  };
-
-  nativeBuildInputs = [ cmake flex bison pkg-config postgresql ];
-
-  buildInputs = [ openssl ]
-    ++ lib.optionals stdenv.isLinux [ systemd ];
-
-  cmakeFlags = [ "-DFLB_METRICS=ON" "-DFLB_HTTP_SERVER=ON" "-DFLB_SQLDB=ON" "-DFLB_OUT_PGSQL=ON" "-DFLB_IN_SYSTEMD=ON" ];
-
-  patches = lib.optionals stdenv.isDarwin [ ./fix-luajit-darwin.patch ];
-
-  NIX_CFLAGS_COMPILE = lib.optionals stdenv.cc.isGNU [
-    # _FORTIFY_SOURCE requires compiling with optimization (-O)
-    "-O"
-    # Needed due to bundled mbedtls
-    "-Wno-error=format"
-    "-Wno-error=format-truncation"
-  ];
-
-
-  outputs = [ "out" "dev" ];
-
-  postPatch = ''
-    substituteInPlace src/CMakeLists.txt \
-      --replace /lib/systemd $out/lib/systemd
-  '';
-
-  meta = with lib; {
-    description = "Log forwarder and processor, part of Fluentd ecosystem";
-    homepage = "https://fluentbit.io";
-    maintainers = with maintainers; [ samrose fpletz ];
-    license = licenses.asl20;
-    platforms = platforms.unix;
-  };
-}