]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/files-watcher/flake.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / files-watcher / flake.nix
index 29ea428dba533a64b88f1cf73dd0ccc32f164954..3be566d9fb0d08e64d5bf7f1238381a28b1c447b 100644 (file)
@@ -2,6 +2,8 @@
   description = "Module to watch fo file changes to force restart systemd service";
   outputs = { self }: {
     nixosModule = { config, lib, pkgs, ... }: let cfg = config.services.filesWatcher; in with lib; {
+      # Necessary for situations where flake gets included multiple times
+      key = builtins.hashString "sha256" (builtins.path { path = self.sourceInfo.outPath; name = "source"; });
       options = {
         services.filesWatcher = with lib.types; mkOption {
           default = {};