]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - environments/immae-eu.nix
Re-enable flrn and slrn
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
index 0322b53ae34fe7c49b1ec4437dd33bfa2b32225e..04a9e9c07fa64c98f982579072a70c4be6929533 100644 (file)
@@ -4,7 +4,7 @@ let
   # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
   paths = [
     # archives
-    lzo unzip bzip2 p7zip xz
+    lzo unzip bzip2 xz
     # unrar is unfree
 
     # backups
@@ -17,8 +17,8 @@ let
     boinctui
 
     # cryptocurrencies
-    cardano cardano-cli sia monero_0_15_0_0
-    xmr-stak
+    cardano cardano-cli sia monero
+    # failing xmr-stak
     solc
     iota-cli-app
 
@@ -54,11 +54,12 @@ let
     # monitoring
     cnagios mtop pg_activity nagios-cli mtr
     iftop htop iotop iperf bonfire
-    goaccess tcpdump tshark tcpflow mitmproxy
+    goaccess tcpdump tshark tcpflow
+    mitmproxy
     # nagnu
 
     # messaging/forums/news
-    #flrn slrn
+    flrn slrn
     telegram-cli telegram-history-dump telegramircd
     weechat profanity
     newsboat irssi
@@ -66,7 +67,7 @@ let
     # nix
     yarn2nix-moretea.yarn2nix nix
     nixops nix-prefetch-scripts nix-generate-from-cpan
-    bundix nodePackages.bower2nix
+    bundix nodePackages.bower2nix nix-diff
     nodePackages.node2nix niv
     # (nixos {}).nixos-generate-config
     # (nixos {}).nixos-install
@@ -88,6 +89,7 @@ let
     vimPlugins.vim-plug
     (vim_configurable.override { python = python3; })
     mailcap
+    webapps.surfer
 
     # password management
     (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
@@ -115,15 +117,18 @@ let
     # system tools
     telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
     wget patchelf rename tmux (lib.meta.hiPrio nettools)
-    vlock mosh manpages openssl
+    vlock mosh manpages openssl openssl.doc openssl.man
+    sshfs
 
     # other tools
     pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
 
     # Terraform + AWS
     terraform_0_12 awscli
-    (ansible.override { python2 = python3; }) python3Packages.boto
+    ansible python3Packages.boto
     openvpn
+
+    zsh-completions
   ];
 in
 buildEnv {