]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Make the use of nixpkgs more homogeneous for env
[perso/Immae/Config/Nix.git] / default.nix
index b1ae800027ceffcf35e5c0f9d4cfb5e20864cfbb..e5fc5f4ac598e741772c53c48331a7775fc27062 100644 (file)
@@ -1,5 +1,5 @@
-with import <immaeNixpkgsNext> {};
-with import ./libs.nix { nixpkgs = import <immaeNixpkgsNext> {}; };
+with import <nixpkgs> {};
+with import ./libs.nix { nixpkgs = import <nixpkgs> {}; };
 let
   mypkgs = {};
 
@@ -93,7 +93,7 @@ let
     };
   };
 
-  mypkgs.terminal-velocity = with python3Packages; buildPythonApplication rec {
+  mypkgs.terminal-velocity = with python36Packages; buildPythonApplication rec {
     pname = "terminal-velocity-git";
     version = "0.2.0";
 
@@ -161,6 +161,7 @@ let
     configureFlags = [
       "--with-etc-dir=/etc/cnagios"
       "--with-var-dir=/var/lib/naemon"
+      "--with-status-file=/var/lib/naemon/status.dat"
       "--with-nagios-data=4"
     ];
 
@@ -679,4 +680,7 @@ in
     inherit bc;
     inherit cpulimit;
     inherit dmenu st;
+    inherit poppler_utils;
+    inherit tmux;
+    inherit netcat-gnu;
   }