]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Use more up to date version of yarn2nix
[perso/Immae/Config/Nix.git] / default.nix
index b36cfc8be68ebdf5a2c94a65e7fe61122311fafb..d003e908fe21301c13a13c674bee07909e1ab4dc 100644 (file)
@@ -2,20 +2,6 @@ with import ./libs.nix;
 with import <nixpkgs> {};
 let
   mypkgs = {};
-  postHook =  ''
-    header() {
-      echo -ne "\033[1;36m"
-      echo -n "$1"
-      echo -e "\033[0m"
-    }
-
-    echoCmd() {
-      printf "\033[1;34m%s:\033[0m" "$1"
-      shift
-      printf ' %q' "$@"
-      echo
-    }
-  '';
 
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
@@ -324,6 +310,7 @@ let
       (with perlPackages; [ TimeDate FileWhich TextIconv ]);
   };
 
+  mypkgs.yarn2nix = yarn2nixPackage.yarn2nix;
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -346,7 +333,7 @@ in
     inherit abook khard khal;
     inherit graphicsmagick;
     inherit youtube-dl;
-    inherit ncmpc;
+    inherit ncmpc ncmpcpp;
     inherit cadaver;
     inherit mairix notmuch;
     inherit ctags;
@@ -363,6 +350,9 @@ in
     inherit bogofilter;
     inherit mtr;
     inherit nixops;
+    inherit urlview;
+    inherit rr;
+    inherit nix-zsh-completions;
     stgit = gitAndTools.stgit;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
@@ -383,6 +373,5 @@ in
     inherit notmuch;
     stgit = gitAndTools.stgit;
     inherit bundix;
-    inherit yarn2nix;
     bower2nix = nodePackages.bower2nix;
   })