]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Move nixpkgs import to libs
[perso/Immae/Config/Nix.git] / default.nix
index 9f14e5a33ce47a347e190ce38fec8731f886e2ec..c32d23f569e6ed47d3058c435958f8ac79c46fd1 100644 (file)
@@ -1,5 +1,7 @@
-with import <nixpkgs> {};
+with import ./libs.nix;
+with nixpkgs_unstable;
 let
+  stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
   postHook =  ''
     header() {
@@ -16,24 +18,6 @@ let
     }
   '';
 
-  fetchedGithub = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchFromGitHub json.github;
-    };
-
-  fetchedGit = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchgit json.git;
-    };
-
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";
@@ -101,7 +85,7 @@ let
     };
   };
 
-  buildPerlPackage = callPackage <nixpkgs/pkgs/development/perl-modules/generic> { };
+  buildPerlPackage = perlPackages.buildPerlPackage;
   mypkgs.note = buildPerlPackage rec {
     name = "note-1.3.26";
     src = fetchurl {
@@ -316,6 +300,7 @@ in
     inherit keybase;
     inherit bogofilter;
     inherit mtr;
+    inherit nixops;
     #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;