]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Move nixpkgs import to libs
[perso/Immae/Config/Nix.git] / default.nix
index 61b5d25504d376414dec2c48e6e432ad0ca72bce..c32d23f569e6ed47d3058c435958f8ac79c46fd1 100644 (file)
@@ -1,5 +1,7 @@
-with import <nixpkgs> {};
+with import ./libs.nix;
+with nixpkgs_unstable;
 let
+  stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
   postHook =  ''
     header() {
@@ -16,24 +18,6 @@ let
     }
   '';
 
-  fetchedGithub = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchFromGitHub json.github;
-    };
-
-  fetchedGit = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchgit json.git;
-    };
-
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";
@@ -101,7 +85,7 @@ let
     };
   };
 
-  buildPerlPackage = callPackage <nixpkgs/pkgs/development/perl-modules/generic> { };
+  buildPerlPackage = perlPackages.buildPerlPackage;
   mypkgs.note = buildPerlPackage rec {
     name = "note-1.3.26";
     src = fetchurl {
@@ -257,6 +241,26 @@ let
   #     cp docs/nagnu.8 $out/share/man/man8
   #     '';
   # });
+
+  mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
+    buildPhase = ''
+      export GIT_SSL_CAINFO=/etc/ssl/certs/ca-certificates.crt
+      export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
+
+      bundle install --deployment --without development test
+      yarn install --pure-lockfile
+    '';
+    installPhase = ''
+      cp -a . $out
+    '';
+    propagatedBuildInputs = [
+      zlib icu libchardet git bundler yarn
+      protobuf protobufc libidn libpqxx nodejs
+      imagemagick ffmpeg libxml2 libxslt pkgconfig
+      autoconf bison libyaml readline ncurses libffi gdbm
+      jemalloc which postgresql python3
+    ];
+  });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -296,6 +300,8 @@ in
     inherit keybase;
     inherit bogofilter;
     inherit mtr;
+    inherit nixops;
+    #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
     #inherit nixos;