]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Move nixpkgs import to libs
[perso/Immae/Config/Nix.git] / default.nix
index 3772d44afd6e8c64549307f42e226d24fb2bd1f9..c32d23f569e6ed47d3058c435958f8ac79c46fd1 100644 (file)
@@ -1,10 +1,5 @@
-with import (builtins.fetchTarball {
-  # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
-  # versions
-  name = "nixos-unstable-2018-12-08";
-  url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
-  sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
-}) {};
+with import ./libs.nix;
+with nixpkgs_unstable;
 let
   stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
@@ -23,24 +18,6 @@ let
     }
   '';
 
-  fetchedGithub = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchFromGitHub json.github;
-    };
-
-  fetchedGit = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchgit json.git;
-    };
-
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";