]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add note taking applications
[perso/Immae/Config/Nix.git] / default.nix
index 4592eefe2bcff94d6518aa6f72075c0e3c7c8afa..c2fe492c626ed84e583b8e9fc1db3303b9499f87 100644 (file)
@@ -86,6 +86,42 @@ let
     };
   };
 
+  buildPerlPackage = callPackage <nixpkgs/pkgs/development/perl-modules/generic> { };
+  note = buildPerlPackage rec {
+    name = "note-1.3.26";
+    src = fetchurl {
+      url = "mirror://cpan/authors/id/T/TL/TLINDEN/${name}.tar.gz";
+      sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
+    };
+    outputs = ["out" "man"];
+    buildInputs = [ perlPackages.YAML ];
+    meta = with stdenv.lib; {
+      description = "A perl script for maintaining notes";
+      homepage    = http://www.daemon.de/NOTE;
+      license     = licenses.gpl3;
+      maintainers = with maintainers; [ { name  = "T.v.Dein"; email = "tlinden@cpan.org"; } ];
+      platforms   = platforms.unix;
+    };
+  };
+
+  terminal_velocity = with python2Packages; buildPythonApplication rec {
+    pname = "terminal-velocity-git";
+    version = "0.2.0";
+
+    patches = [
+      # FIXME: update this patch when version changes
+      ./patches/terminal_velocity_fix_build.patch
+      ./patches/terminal_velocity_sort_found_notes.patch
+    ];
+
+    propagatedBuildInputs = [ chardet urwid sh pyyaml ];
+    buildInputs = [ m2r restructuredtext_lint pygments ];
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "13yrkcmvh5h5fwnai61sbmqkrjyisz08n62pq0ada2lyyqf7g6b9";
+    };
+  };
 in
   {
     inherit nix-prefetch-scripts;
@@ -109,5 +145,6 @@ in
     inherit ranger;
     inherit profanity;
     inherit weechat;
+    inherit note terminal_velocity;
     #inherit nixos;
   }