]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add a bunch of programs
[perso/Immae/Config/Nix.git] / default.nix
index 92dea9cdb5c19a22730b134f66c87a1060343f09..95caf5158e1f0880e63096abcea0b57b6f150353 100644 (file)
@@ -78,7 +78,7 @@ let
 
   nixos = import ./nixos_tools.nix {};
 
-  pass = nixpkgs.pass.overrideAttrs (oldAttrs:
+  pass = (nixpkgs.pass.withExtensions (exts: [ exts.pass-otp ])).overrideAttrs (oldAttrs:
     fetchedGit ./fetched/pass.json // {
       patches = oldAttrs.patches ++ [ ./patches/pass-fix-pass-init.patch ];
     }
@@ -200,6 +200,28 @@ let
     propagatedBuildInputs = [ perl ncurses ];
   });
 
+  nagios-cli = python2Packages.buildPythonApplication (fetchedGithub ./fetched/nagios-cli.json);
+
+  pg_activity = with python2Packages; buildPythonApplication (fetchedGithub ./fetched/pg_activity.json // rec {
+    propagatedBuildInputs = [ psycopg2 psutil ];
+  });
+
+  pgloader = stdenv.mkDerivation (fetchedGithub ./fetched/pgloader.json // rec {
+    buildInputs = [ sbcl cacert sqlite freetds libzip curl git openssl makeWrapper ];
+    LD_LIBRARY_PATH = stdenv.lib.makeLibraryPath [ sqlite libzip curl git openssl freetds ];
+    buildPhase = ''
+      export PATH=$PATH:$out/bin
+      export HOME=$TMPDIR
+      make pgloader
+    '';
+    dontStrip = true;
+    enableParallelBuilding = false;
+    installPhase = ''
+      install -Dm755 build/bin/pgloader "$out/bin/pgloader"
+      wrapProgram $out/bin/pgloader --prefix LD_LIBRARY_PATH : "${LD_LIBRARY_PATH}"
+    '';
+  });
+
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -225,10 +247,26 @@ in
     inherit pass;
     inherit ranger;
     inherit profanity;
-    inherit weechat;
+    inherit weechat irssi;
     inherit note terminal_velocity;
     inherit mtop;
     inherit tiv;
-    inherit cnagios;
+    inherit cnagios nagios-cli;
+    inherit abook khard khal;
+    inherit graphicsmagick;
+    inherit youtube-dl;
+    inherit pg_activity pgloader;
+    inherit ncmpc;
+    inherit cadaver;
+    inherit mairix notmuch;
+    inherit ctags;
+    inherit s3cmd;
+    inherit solc; # solidity
+    inherit rtorrent;
+    inherit strace;
+    inherit vdirsyncer;
+    inherit w3m lynx links;
+    inherit gitRepo;
+    inherit valgrind;
     #inherit nixos;
   }