]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Move Émilia's website
[perso/Immae/Config/Nix.git] / default.nix
index 2f10ee83c089eb9c5c2b4d582dd5f951a646979f..75e1e0a391035babda8137151457dff11b317da2 100644 (file)
@@ -1,3 +1,4 @@
+with import ./libs.nix;
 with import <nixpkgs> {};
 let
   mypkgs = {};
@@ -16,24 +17,6 @@ let
     }
   '';
 
-  fetchedGithub = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchFromGitHub json.github;
-    };
-
-  fetchedGit = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchgit json.git;
-    };
-
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";
@@ -92,7 +75,7 @@ let
     configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
   });
 
-  mypkgs.weechat = weechat.override {
+  mypkgs.weechat = nixpkgs_unstable.weechat.override {
     configure = { availablePlugins, ... }: {
       plugins = with availablePlugins; [
          (python.withPackages (ps: with ps; [websocket_client emoji]))
@@ -101,7 +84,7 @@ let
     };
   };
 
-  buildPerlPackage = callPackage <nixpkgs/pkgs/development/perl-modules/generic> { };
+  buildPerlPackage = perlPackages.buildPerlPackage;
   mypkgs.note = buildPerlPackage rec {
     name = "note-1.3.26";
     src = fetchurl {
@@ -109,7 +92,7 @@ let
       sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
     };
     outputs = ["out" "man"];
-    propragatedBuildInputs = [ perlPackages.YAML ];
+    propagatedBuildInputs = [ perlPackages.YAML ];
     meta = with stdenv.lib; {
       description = "A perl script for maintaining notes";
       homepage    = http://www.daemon.de/NOTE;
@@ -129,7 +112,7 @@ let
       ./patches/terminal_velocity_sort_found_notes.patch
     ];
 
-    propagatedBuildInputs = [ chardet urwid sh pyyaml ];
+    propagatedBuildInputs = [ chardet urwid nixpkgs_unstable.python2Packages.sh pyyaml ];
     buildInputs = [ m2r restructuredtext_lint pygments ];
 
     src = fetchPypi {
@@ -258,25 +241,17 @@ let
   #     '';
   # });
 
-  mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
-    buildPhase = ''
-      export GIT_SSL_CAINFO=/etc/ssl/certs/ca-certificates.crt
-      export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
-
-      bundle install --deployment --without development test
-      yarn install --pure-lockfile
-    '';
-    installPhase = ''
-      cp -a . $out
-    '';
-    propagatedBuildInputs = [
-      zlib icu libchardet git bundler yarn
-      protobuf protobufc libidn libpqxx nodejs
-      imagemagick ffmpeg libxml2 libxslt pkgconfig
-      autoconf bison libyaml readline ncurses libffi gdbm
-      jemalloc which postgresql python3
-    ];
+  mypkgs.goaccess = goaccess.overrideAttrs(old: rec {
+    name = "goaccess-${version}";
+    version = "1.3";
+    src = fetchurl {
+      url = "https://tar.goaccess.io/${name}.tar.gz";
+      sha256 = "16vv3pj7pbraq173wlxa89jjsd279004j4kgzlrsk1dz4if5qxwc";
+    };
+    configureFlags = old.configureFlags ++ [ "--enable-tcb=btree" ];
+    buildInputs = old.buildInputs ++ [ tokyocabinet bzip2 ];
   });
+
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -286,7 +261,6 @@ in
     inherit timewarrior;
     inherit sc-im;
     inherit pal;
-    inherit duplicity duply;
     inherit pdftk;
     inherit googler;
     inherit jrnl;
@@ -317,8 +291,26 @@ in
     inherit bogofilter;
     inherit mtr;
     inherit nixops;
-    #inherit mastodon;
+    stgit = gitAndTools.stgit;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
     #inherit nixos;
-  }
+  } // (with nixpkgs_unstable; {
+    inherit googler;
+    inherit khal;
+    inherit newsboat;
+    inherit xmr-stak;
+    inherit urlwatch;
+    inherit graphicsmagick;
+    inherit ncmpc;
+    inherit solc;
+    inherit w3m lynx links;
+    inherit valgrind;
+    inherit ranger;
+    inherit strace;
+    inherit notmuch;
+    stgit = gitAndTools.stgit;
+    inherit bundix;
+    inherit yarn2nix;
+    bower2nix = nodePackages.bower2nix;
+  })