]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add cacert as dependency when building private git
[perso/Immae/Config/Nix.git] / default.nix
index fc7d1ff5170db708c85457528441effce8802564..7580431a15d8011457a6a82ea769dadb1cedc28a 100644 (file)
@@ -1,5 +1,7 @@
-with import <nixpkgs> {};
+with import ./libs.nix;
+with nixpkgs_unstable;
 let
+  stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
   postHook =  ''
     header() {
@@ -16,24 +18,6 @@ let
     }
   '';
 
-  fetchedGithub = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchFromGitHub json.github;
-    };
-
-  fetchedGit = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchgit json.git;
-    };
-
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";
@@ -101,7 +85,7 @@ let
     };
   };
 
-  buildPerlPackage = callPackage <nixpkgs/pkgs/development/perl-modules/generic> { };
+  buildPerlPackage = perlPackages.buildPerlPackage;
   mypkgs.note = buildPerlPackage rec {
     name = "note-1.3.26";
     src = fetchurl {
@@ -238,6 +222,45 @@ let
       patches = [];
     }
   );
+
+  mypkgs.neomutt = neomutt.overrideAttrs (old:
+    rec {
+      buildInputs = old.buildInputs ++ [ gdbm ];
+      configureFlags = old.configureFlags ++ [ "--gdbm" ];
+    }
+  );
+
+  # mypkgs.nagnu = stdenv.mkDerivation (fetchedGithub ./fetched/nagnu.json // rec {
+  #   buildInputs = [ ncurses curl ];
+  #   installPhase = ''
+  #     mkdir -p $out/bin
+  #     cp nagnu $out/bin
+  #     mkdir -p $out/share/doc/nagnu
+  #     cp nagnu.conf.sample $out/share/doc/nagnu
+  #     mkdir -p $out/share/man/man8
+  #     cp docs/nagnu.8 $out/share/man/man8
+  #     '';
+  # });
+
+  mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
+    buildPhase = ''
+      export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
+      export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
+
+      bundle install --deployment --without development test
+      yarn install --pure-lockfile
+    '';
+    installPhase = ''
+      cp -a . $out
+    '';
+    propagatedBuildInputs = [
+      zlib icu libchardet git bundler yarn
+      protobuf protobufc libidn libpqxx nodejs
+      imagemagick ffmpeg libxml2 libxslt pkgconfig
+      autoconf bison libyaml readline ncurses libffi gdbm
+      jemalloc which postgresql python3 cacert
+    ];
+  });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -276,6 +299,9 @@ in
     inherit iotop iperf;
     inherit keybase;
     inherit bogofilter;
+    inherit mtr;
+    inherit nixops;
+    #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
     #inherit nixos;