]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add some small patches to unclutter the home directory
[perso/Immae/Config/Nix.git] / default.nix
index c8a3c939e4e739a6a8e217eb2e756d4f839833f1..49013b9f1de35373ddce3c0b943f85d84669f24c 100644 (file)
@@ -2,20 +2,6 @@ with import ./libs.nix;
 with import <nixpkgs> {};
 let
   mypkgs = {};
-  postHook =  ''
-    header() {
-      echo -ne "\033[1;36m"
-      echo -n "$1"
-      echo -e "\033[0m"
-    }
-
-    echoCmd() {
-      printf "\033[1;34m%s:\033[0m" "$1"
-      shift
-      printf ' %q' "$@"
-      echo
-    }
-  '';
 
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
@@ -102,7 +88,7 @@ let
     };
   };
 
-  mypkgs.terminal_velocity = with python2Packages; buildPythonApplication rec {
+  mypkgs.terminal-velocity = with python2Packages; buildPythonApplication rec {
     pname = "terminal-velocity-git";
     version = "0.2.0";
 
@@ -115,6 +101,9 @@ let
     propagatedBuildInputs = [ chardet urwid nixpkgs_unstable.python2Packages.sh pyyaml ];
     buildInputs = [ m2r restructuredtext_lint pygments ];
 
+    postInstall = ''
+      rm $out/bin/terminal_velocity
+      '';
     src = fetchPypi {
       inherit pname version;
       sha256 = "13yrkcmvh5h5fwnai61sbmqkrjyisz08n62pq0ada2lyyqf7g6b9";
@@ -315,6 +304,7 @@ let
       done
 
       sed -i "$out/bin/muttprint" -e "s|^#\!\(.*[ /]perl.*\)$|#\!\1$perlFlags|"
+      sed -i "$out/bin/muttprint" -e "s|ENV{HOME}/.muttprintrc|ENV{XDG_CONFIG_HOME}/muttprint/muttprintrc|"
 
       wrapProgram $out/bin/muttprint \
         --prefix PATH : ${lib.makeBinPath [ psutils dialog
@@ -324,6 +314,59 @@ let
       (with perlPackages; [ TimeDate FileWhich TextIconv ]);
   };
 
+  mypkgs.yarn2nix = yarn2nixPackage.yarn2nix;
+
+  mypkgs.sc-im = sc-im.overrideAttrs (old: {
+    buildPhase = ''
+      cd src
+      sed -i Makefile -e 's@\...name.info@.local/state/$(name)info@'
+      cd ..
+      '' + old.buildPhase;
+  });
+
+  mypkgs.notmuch-vim = stdenv.mkDerivation rec {
+    name = "notmuch-vim-${version}";
+    version = nixpkgs_unstable.notmuch.version;
+    outputs = [ "out" ];
+    src = nixpkgs_unstable.notmuch.src;
+    phases = [ "unpackPhase" "installPhase" ];
+    installPhase = ''
+      make -C vim DESTDIR=$out prefix="/share/vim/vimfiles" install
+      '';
+  };
+
+  mypkgs.notmuch-python2 = stdenv.mkDerivation rec {
+    name = "notmuch-python2-${version}";
+    version = nixpkgs_unstable.notmuch.version;
+    outputs = [ "out" ];
+    buildInputs = [ python2Packages.sphinx python2Packages.python ];
+    src = nixpkgs_unstable.notmuch.src;
+    phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
+    buildPhase = ''
+      cd bindings/python
+      python setup.py build
+      '';
+    installPhase = ''
+      python setup.py install --prefix=$out --optimize=1
+      '';
+  };
+
+  mypkgs.notmuch-python3 = stdenv.mkDerivation rec {
+    name = "notmuch-python3-${version}";
+    version = nixpkgs_unstable.notmuch.version;
+    outputs = [ "out" ];
+    buildInputs = [ nixpkgs_unstable.python3Packages.sphinx nixpkgs_unstable.python3Packages.python ];
+    src = nixpkgs_unstable.notmuch.src;
+    phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
+    buildPhase = ''
+      cd bindings/python
+      python setup.py build
+      '';
+    installPhase = ''
+      python setup.py install --prefix=$out --optimize=1
+      '';
+  };
+
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -331,7 +374,6 @@ in
     inherit nix-prefetch-scripts;
     inherit nix-generate-from-cpan;
     inherit timewarrior;
-    inherit sc-im;
     inherit pal;
     inherit pdftk;
     inherit googler;
@@ -364,6 +406,9 @@ in
     inherit mtr;
     inherit nixops;
     inherit urlview;
+    inherit rr;
+    inherit nix-zsh-completions;
+    inherit browsh;
     stgit = gitAndTools.stgit;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
@@ -381,9 +426,8 @@ in
     inherit valgrind;
     inherit ranger;
     inherit strace;
-    inherit notmuch;
+    inherit notmuch notmuch-mutt;
     stgit = gitAndTools.stgit;
     inherit bundix;
-    inherit yarn2nix;
     bower2nix = nodePackages.bower2nix;
   })