]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add vnc server programs
[perso/Immae/Config/Nix.git] / default.nix
index 0c7cd7bc5fe200b1e29aba1cb9ab07b519a4f86d..444d29d8b4a67509b29747daaf2240aa97d82bcf 100644 (file)
@@ -1,5 +1,5 @@
-with import ./libs.nix;
-with import <nixpkgs> {};
+with import <immaeNixpkgsNext> {};
+with import ./libs.nix { nixpkgs = import <immaeNixpkgsNext> {}; };
 let
   mypkgs = {};
 
@@ -26,11 +26,13 @@ let
     }
   );
 
-  mypkgs.weboob = pythonPackages.weboob.overrideAttrs (old: rec {
-    postInstall = ''${old.postInstall or ""}
-      mkdir -p $out/share/bash-completion/completions/
-      cp tools/weboob_bash_completion $out/share/bash-completion/completions/weboob
-    '';
+  mypkgs.weboob = (pythonPackages.weboob.overridePythonAttrs {
+      setupPyBuildFlags = [ "--no-qt" "--xdg" ];
+    }).overrideAttrs (old: rec {
+      postInstall = ''${old.postInstall or ""}
+        mkdir -p $out/share/bash-completion/completions/
+        cp tools/weboob_bash_completion $out/share/bash-completion/completions/weboob
+      '';
   });
 
   mypkgs.slrn = slrn.overrideAttrs (old: rec {
@@ -61,7 +63,17 @@ let
     configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
   });
 
-  mypkgs.weechat = nixpkgs_unstable.weechat.override {
+  mypkgs.weechat = (wrapWeechat (
+    weechat-unwrapped.overrideAttrs (old: rec {
+      version = "2.3";
+      name = "weechat-${version}";
+      src = fetchurl {
+        url = "https://weechat.org/files/src/weechat-${version}.tar.bz2";
+        sha256 = "0mi4pfnyny0vqc35r0scn6yy21y790a5iwq8ms7kch7b7z11jn9w";
+      };
+      patches = [];
+    })
+  ) {}).override {
     configure = { availablePlugins, ... }: {
       plugins = with availablePlugins; [
          (python.withPackages (ps: with ps; [websocket_client emoji]))
@@ -89,18 +101,19 @@ let
     };
   };
 
-  mypkgs.terminal-velocity = with python2Packages; buildPythonApplication rec {
+  mypkgs.terminal-velocity = with python3Packages; buildPythonApplication rec {
     pname = "terminal-velocity-git";
     version = "0.2.0";
 
     patches = [
+      ./patches/terminal_velocity_sort_found_notes.patch
+      ./patches/terminal_velocity_python3_support.patch
       # FIXME: update this patch when version changes
       ./patches/terminal_velocity_fix_build.patch
-      ./patches/terminal_velocity_sort_found_notes.patch
     ];
 
-    propagatedBuildInputs = [ chardet urwid nixpkgs_unstable.python2Packages.sh pyyaml ];
-    buildInputs = [ m2r restructuredtext_lint pygments ];
+    propagatedBuildInputs = [ chardet urwid (sh.overridePythonAttrs { doCheck = false; }) pyyaml ];
+    buildInputs = [ m2r (restructuredtext_lint.overridePythonAttrs { doCheck = false; }) pygments ];
 
     postInstall = ''
       rm $out/bin/terminal_velocity
@@ -456,9 +469,9 @@ let
 
   mypkgs.notmuch-vim = stdenv.mkDerivation rec {
     name = "notmuch-vim-${version}";
-    version = nixpkgs_unstable.notmuch.version;
+    version = notmuch.version;
     outputs = [ "out" ];
-    src = nixpkgs_unstable.notmuch.src;
+    src = notmuch.src;
     phases = [ "unpackPhase" "installPhase" ];
     installPhase = ''
       make -C vim DESTDIR=$out prefix="/share/vim/vimfiles" install
@@ -467,10 +480,10 @@ let
 
   mypkgs.notmuch-python2 = stdenv.mkDerivation rec {
     name = "notmuch-python2-${version}";
-    version = nixpkgs_unstable.notmuch.version;
+    version = notmuch.version;
     outputs = [ "out" ];
     buildInputs = [ python2Packages.sphinx python2Packages.python ];
-    src = nixpkgs_unstable.notmuch.src;
+    src = notmuch.src;
     phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
     buildPhase = ''
       cd bindings/python
@@ -483,10 +496,10 @@ let
 
   mypkgs.notmuch-python3 = stdenv.mkDerivation rec {
     name = "notmuch-python3-${version}";
-    version = nixpkgs_unstable.notmuch.version;
+    version = notmuch.version;
     outputs = [ "out" ];
-    buildInputs = [ nixpkgs_unstable.python3Packages.sphinx nixpkgs_unstable.python3Packages.python ];
-    src = nixpkgs_unstable.notmuch.src;
+    buildInputs = [ python3Packages.sphinx python3Packages.python ];
+    src = notmuch.src;
     phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
     buildPhase = ''
       cd bindings/python
@@ -534,6 +547,83 @@ let
         install -Dm644 "$src/config" -t "$out/etc/telegramircd/"
         '';
     };
+
+  mypkgs.lesspipe = lesspipe.overrideAttrs(old: {
+    configureFlags = (old.configureFlags or []) ++ [ "--yes" ];
+  });
+
+  mypkgs.genius = stdenv.mkDerivation rec {
+    name = "genius-${version}";
+    version = "1.0.24";
+    src = fetchurl {
+      url = "https://download.gnome.org/sources/genius/1.0/${name}.tar.xz";
+      sha256 = "772f95f6ae4716d39bb180cd50e8b6b9b074107bee0cd083b825e1e6e55916b6";
+    };
+    buildInputs = [
+      mpfr glib hicolor-icon-theme gtk2 intltool gnome-doc-utils python3 gnome2.gtksourceview
+      autoconf automake libtool ncurses readline pkg-config
+    ];
+    preConfigure = ''
+      autoreconf -fi
+      '';
+    preBuild = ''
+      sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+      '';
+  };
+
+  mypkgs.unicode = let
+    version = "12.0";
+    version-full = "${version}.0";
+    files = {
+      emoji-data = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-data.txt";
+        sha256 = "03sf7h1d6kb9m5s02lif88jsi5kjszpkfvcymaqxj8ds70ar9pgv";
+      };
+      emoji-sequences = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-sequences.txt";
+        sha256 = "1hghki2rn3n7m4lwpwi2a5wrsf2nij4bxga9ldabx4g0g2k23svs";
+      };
+      emoji-test = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-test.txt";
+        sha256 = "1dqd0fh999mh6naj816ni113m9dimfy3ih9nffjq2lrv9mmlgdck";
+      };
+      emoji-variation-sequences = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-variation-sequences.txt";
+        sha256 = "1cccwx5bl79w4c19vi5dhjqxrph92s8hihp9y8s2cqvdzmgbln7a";
+      };
+      emoji-zwj-sequences = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-zwj-sequences.txt";
+        sha256 = "1l791nbijmmhwa7kmvfn8gp26ban512l6mgqpz1mnbq3xm19181n";
+      };
+    };
+    zippedFiles = {
+      UCD = fetchurl {
+        url = "http://www.unicode.org/Public/zipped/${version-full}/UCD.zip";
+        sha256 = "1ighy39cjkmqnv1797wrxjz76mv1fdw7zp5j04q55bkwxsdkvrmh";
+      };
+      Unihan = fetchurl {
+        url = "http://www.unicode.org/Public/zipped/${version-full}/Unihan.zip";
+        sha256 = "1kfdhgg2gm52x3s07bijb5cxjy0jxwhd097k5lqhvzpznprm6ibf";
+      };
+    };
+  in
+    pkgs.runCommand "unicode" {
+      buildInputs = [ libarchive ];
+    } ''
+    mkdir -p $out/share/unicode
+    ${builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList (n: u: "install -Dm644 ${u} $out/share/unicode/emoji/${n}.txt") files)}
+    ${builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList (n: u: ''
+      install -Dm644 ${u} $out/share/unicode/${n}.zip
+      bsdtar -C "$out/share/unicode" -x -f "$out/share/unicode/${n}.zip"
+      '') zippedFiles)}
+    '';
+
+  mypkgs.dwm = dwm.overrideAttrs(old: rec {
+    postPatch = ''
+      cp ${./patches/dwm_config.h} ./config.h
+      '';
+  });
+
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -545,7 +635,7 @@ in
     inherit pdftk;
     inherit googler;
     inherit jrnl;
-    inherit apg;
+    inherit apg pwgen;
     inherit newsboat;
     inherit vcsh;
     inherit xmr-stak;
@@ -579,25 +669,22 @@ in
     inherit monero;
     inherit nextcloud-client;
     inherit feh imagemagick;
-    stgit = gitAndTools.stgit;
-    # todo: lx* ?, unrar, unzip, zeromq?
-    #inherit nextcloud-client;
-    #inherit nixos;
-  } // (with nixpkgs_unstable; {
-    inherit googler;
-    inherit khal;
-    inherit newsboat;
-    inherit xmr-stak;
-    inherit urlwatch;
-    inherit graphicsmagick;
-    inherit ncmpc;
-    inherit solc;
-    inherit w3m lynx links;
-    inherit valgrind;
-    inherit ranger;
-    inherit strace;
-    inherit notmuch notmuch-mutt;
+    inherit lftp;
     stgit = gitAndTools.stgit;
     inherit bundix;
     bower2nix = nodePackages.bower2nix;
-  })
+    inherit firefox;
+    inherit jq;
+    inherit lzo unzip bzip2 p7zip xz;
+    # unrar is unfree
+    inherit tig;
+    #inherit nixos;
+    inherit emacs26-nox;
+    inherit highlight sourceHighlight;
+    pygmentize = python3Packages.pygments;
+    inherit iftop htop;
+    inherit fetchmail;
+    inherit bc;
+    inherit cpulimit;
+    inherit dmenu st;
+  }