]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Use tagged nixpkgs instead of last unstable version to control upgrades
[perso/Immae/Config/Nix.git] / default.nix
index 9f14e5a33ce47a347e190ce38fec8731f886e2ec..3772d44afd6e8c64549307f42e226d24fb2bd1f9 100644 (file)
@@ -1,5 +1,12 @@
-with import <nixpkgs> {};
+with import (builtins.fetchTarball {
+  # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
+  # versions
+  name = "nixos-unstable-2018-12-08";
+  url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
+  sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
+}) {};
 let
+  stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
   postHook =  ''
     header() {
@@ -101,7 +108,7 @@ let
     };
   };
 
-  buildPerlPackage = callPackage <nixpkgs/pkgs/development/perl-modules/generic> { };
+  buildPerlPackage = perlPackages.buildPerlPackage;
   mypkgs.note = buildPerlPackage rec {
     name = "note-1.3.26";
     src = fetchurl {
@@ -316,6 +323,7 @@ in
     inherit keybase;
     inherit bogofilter;
     inherit mtr;
+    inherit nixops;
     #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;