]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add compression tools, less colorization and other tools
[perso/Immae/Config/Nix.git] / default.nix
index d1bd83078d0a76d94278a295923657c6fd13ae64..1f50aa365046a18e29ceff3fdf665837d9afe0ae 100644 (file)
@@ -547,6 +547,10 @@ let
         install -Dm644 "$src/config" -t "$out/etc/telegramircd/"
         '';
     };
+
+    mypkgs.lesspipe = lesspipe.overrideAttrs(old: {
+      configureFlags = (old.configureFlags or []) ++ [ "--yes" ];
+    });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -596,6 +600,13 @@ in
     stgit = gitAndTools.stgit;
     inherit bundix;
     bower2nix = nodePackages.bower2nix;
-    # todo: unrar, unzip
+    inherit firefox;
+    inherit jq;
+    inherit lzo unzip bzip2 p7zip xz;
+    # unrar is unfree
+    inherit tig;
     #inherit nixos;
+    inherit emacs26-nox;
+    inherit highlight sourceHighlight;
+    pygmentize = python3Packages.pygments;
   }