]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Revert personnal nix path
[perso/Immae/Config/Nix.git] / default.nix
index ad9bca7f2a6876ac98063d529db8dffdd513687d..18ea57699b2dbdc40d3a30d6e413ac2e0027b780 100644 (file)
@@ -1,5 +1,5 @@
-with import ./libs.nix;
 with import <immaeNixpkgsNext> {};
+with import ./libs.nix { nixpkgs = import <immaeNixpkgsNext> {}; };
 let
   mypkgs = {};
 
@@ -63,19 +63,11 @@ let
     configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
   });
 
-  mypkgs.weechat = (wrapWeechat (
-    weechat-unwrapped.overrideAttrs (old: rec {
-      version = "2.3";
-      name = "weechat-${version}";
-      src = fetchurl {
-        url = "https://weechat.org/files/src/weechat-${version}.tar.bz2";
-        sha256 = "0mi4pfnyny0vqc35r0scn6yy21y790a5iwq8ms7kch7b7z11jn9w";
-      };
-      patches = [];
-    })
-  ) {}).override {
+  mypkgs.weechat = weechat.override {
     configure = { availablePlugins, ... }: {
       plugins = with availablePlugins; [
+          # Make sure websocket_client is not 0.55.0, it provokes
+          # regular crashes
          (python.withPackages (ps: with ps; [websocket_client emoji]))
          perl
          ruby
@@ -169,6 +161,7 @@ let
     configureFlags = [
       "--with-etc-dir=/etc/cnagios"
       "--with-var-dir=/var/lib/naemon"
+      "--with-status-file=/var/lib/naemon/status.dat"
       "--with-nagios-data=4"
     ];
 
@@ -547,6 +540,83 @@ let
         install -Dm644 "$src/config" -t "$out/etc/telegramircd/"
         '';
     };
+
+  mypkgs.lesspipe = lesspipe.overrideAttrs(old: {
+    configureFlags = (old.configureFlags or []) ++ [ "--yes" ];
+  });
+
+  mypkgs.genius = stdenv.mkDerivation rec {
+    name = "genius-${version}";
+    version = "1.0.24";
+    src = fetchurl {
+      url = "https://download.gnome.org/sources/genius/1.0/${name}.tar.xz";
+      sha256 = "772f95f6ae4716d39bb180cd50e8b6b9b074107bee0cd083b825e1e6e55916b6";
+    };
+    buildInputs = [
+      mpfr glib hicolor-icon-theme gtk2 intltool gnome-doc-utils python3 gnome2.gtksourceview
+      autoconf automake libtool ncurses readline pkg-config
+    ];
+    preConfigure = ''
+      autoreconf -fi
+      '';
+    preBuild = ''
+      sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+      '';
+  };
+
+  mypkgs.unicode = let
+    version = "12.0";
+    version-full = "${version}.0";
+    files = {
+      emoji-data = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-data.txt";
+        sha256 = "03sf7h1d6kb9m5s02lif88jsi5kjszpkfvcymaqxj8ds70ar9pgv";
+      };
+      emoji-sequences = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-sequences.txt";
+        sha256 = "1hghki2rn3n7m4lwpwi2a5wrsf2nij4bxga9ldabx4g0g2k23svs";
+      };
+      emoji-test = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-test.txt";
+        sha256 = "1dqd0fh999mh6naj816ni113m9dimfy3ih9nffjq2lrv9mmlgdck";
+      };
+      emoji-variation-sequences = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-variation-sequences.txt";
+        sha256 = "1cccwx5bl79w4c19vi5dhjqxrph92s8hihp9y8s2cqvdzmgbln7a";
+      };
+      emoji-zwj-sequences = fetchurl {
+        url = "http://www.unicode.org/Public/emoji/${version}/emoji-zwj-sequences.txt";
+        sha256 = "1l791nbijmmhwa7kmvfn8gp26ban512l6mgqpz1mnbq3xm19181n";
+      };
+    };
+    zippedFiles = {
+      UCD = fetchurl {
+        url = "http://www.unicode.org/Public/zipped/${version-full}/UCD.zip";
+        sha256 = "1ighy39cjkmqnv1797wrxjz76mv1fdw7zp5j04q55bkwxsdkvrmh";
+      };
+      Unihan = fetchurl {
+        url = "http://www.unicode.org/Public/zipped/${version-full}/Unihan.zip";
+        sha256 = "1kfdhgg2gm52x3s07bijb5cxjy0jxwhd097k5lqhvzpznprm6ibf";
+      };
+    };
+  in
+    pkgs.runCommand "unicode" {
+      buildInputs = [ libarchive ];
+    } ''
+    mkdir -p $out/share/unicode
+    ${builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList (n: u: "install -Dm644 ${u} $out/share/unicode/emoji/${n}.txt") files)}
+    ${builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList (n: u: ''
+      install -Dm644 ${u} $out/share/unicode/${n}.zip
+      bsdtar -C "$out/share/unicode" -x -f "$out/share/unicode/${n}.zip"
+      '') zippedFiles)}
+    '';
+
+  mypkgs.dwm = dwm.overrideAttrs(old: rec {
+    postPatch = ''
+      cp ${./patches/dwm_config.h} ./config.h
+      '';
+  });
+
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -596,6 +666,18 @@ in
     stgit = gitAndTools.stgit;
     inherit bundix;
     bower2nix = nodePackages.bower2nix;
-    # todo: unrar, unzip
+    inherit firefox;
+    inherit jq;
+    inherit lzo unzip bzip2 p7zip xz;
+    # unrar is unfree
+    inherit tig;
     #inherit nixos;
+    inherit emacs26-nox;
+    inherit highlight sourceHighlight;
+    pygmentize = python3Packages.pygments;
+    inherit iftop htop;
+    inherit fetchmail;
+    inherit bc;
+    inherit cpulimit;
+    inherit dmenu st;
   }