]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - config/config.nix
Add postHook to colorize build outputs
[perso/Immae/Config/Nix.git] / config / config.nix
index 0b578356c68f39a1c700a23946accf2bbeaa3b90..d6b471496e5b3369eb5a21b3dfe6b2b628dc0dfc 100644 (file)
@@ -9,5 +9,22 @@
       pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
       extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
     };
+    # This adds header colors to the builds, but it rebuilds the whole
+    # world from scratch, so only use it to debug!
+    # add it as postHook in derivations
+    immaePostHook = ''
+      header() {
+        echo -ne "\033[1;36m"
+        echo -n "$1"
+        echo -e "\033[0m"
+      }
+
+      echoCmd() {
+        printf "\033[1;34m%s:\033[0m" "$1"
+        shift
+        printf ' %q' "$@"
+        echo
+      }
+    '';
   };
 }