]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/private/webapps/piedsjaloux/default.nix
f5370db4af09dc9403498c7aef7e602d5223f42b
[perso/Immae/Config/Nix.git] / pkgs / private / webapps / piedsjaloux / default.nix
1 { environment ? "prod"
2 , varDir ? "/var/lib/piedsjaloux_${environment}"
3 , composerEnv, fetchurl, fetchgit, mylibs }:
4 let
5 app = composerEnv.buildPackage (
6 import ./php-packages.nix { inherit composerEnv fetchurl fetchgit; } //
7 mylibs.fetchedGitPrivate ./piedsjaloux.json //
8 rec {
9 noDev = (environment == "prod");
10 preInstall = ''
11 export SYMFONY_ENV="${environment}"
12 '';
13 # /!\ miniatures and data need to be in the same physical dir due to a
14 # bug in leapt.im (searches for data/../miniatures)
15 postInstall = ''
16 cd $out
17 rm app/config/parameters.yml
18 ln -sf /var/secrets/webapps/${environment}-piedsjaloux app/config/parameters.yml
19 rm -rf var/{logs,cache,data,miniatures,tmp}
20 ln -sf ${varDir}/{logs,cache,data,miniatures,tmp} var/
21 '';
22 passthru = {
23 inherit varDir environment;
24 webRoot = "${app}/web";
25 };
26 });
27 in app