]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/default.nix
616a462ecff00a636fdc88be0ad5bfd4294fa9e7
[perso/Immae/Config/Nix.git] / pkgs / default.nix
1 { pkgs }:
2 with pkgs;
3 let
4 mylibs = import ../lib { inherit pkgs; };
5 in
6 rec {
7 sources = import ../nix/sources.nix;
8 myEnvironments = callPackage ../environments {};
9 boinctui = callPackage ./boinctui {};
10 cnagios = callPackage ./cnagios { inherit mylibs; };
11 commento = callPackage ./commento {};
12 flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
13 genius = callPackage ./genius {};
14 mtop = callPackage ./mtop {};
15 muttprint = callPackage ./muttprint {};
16 mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
17 nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
18 nagnu = callPackage ./nagnu { inherit mylibs; };
19 nb = callPackage ./nb {};
20 note = callPackage ./note {};
21 notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
22 notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
23 notmuch-vim = callPackage ./notmuch/notmuch-vim {};
24 pgloader = callPackage ./pgloader {};
25 predixy = callPackage ./predixy { inherit mylibs; };
26 rrsync_sudo = callPackage ./rrsync_sudo {};
27 signaldctl = callPackage ./signaldctl {};
28 telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
29 telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
30 terminal-velocity = callPackage ./terminal-velocity {};
31 tiv = callPackage ./tiv {};
32 twins = callPackage ./twins {};
33 umami = callPackage ./umami {};
34 unicodeDoc = callPackage ./unicode {};
35
36 cardano = callPackage ./crypto/cardano { inherit mylibs; };
37 cardano-cli = callPackage ./crypto/cardano-cli {};
38 iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
39 sia = callPackage ./crypto/sia {};
40
41 pure-ftpd = callPackage ./pure-ftpd {};
42
43 composerEnv = callPackage ./composer-env {};
44 webapps = callPackage ./webapps { inherit mylibs composerEnv; };
45
46 monitoring-plugins = callPackage ./monitoring-plugins {};
47 naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
48 naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
49 gearmand = callPackage ./gearmand {};
50 status_engine = {
51 module = callPackage ./status_engine/module.nix { inherit mylibs; };
52 worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
53 interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
54 };
55
56 python3PackagesPlus = callPackage ./python-packages {
57 python = python3;
58 inherit mylibs;
59 };
60 dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
61 inherit mylibs;
62 };
63 }