]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/default.nix
25ff9d76280f137ddd7055eeda492087469f126d
[perso/Immae/Config/Nix.git] / pkgs / default.nix
1 { pkgs }:
2 with pkgs;
3 let
4 mylibs = import ../lib { inherit pkgs; };
5 in
6 rec {
7 sources = import ../nix/sources.nix;
8 myEnvironments = callPackage ../environments {};
9 boinctui = callPackage ./boinctui {};
10 cnagios = callPackage ./cnagios { inherit mylibs; };
11 commento = callPackage ./commento {};
12 duply = callPackage ./duply {};
13 flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
14 genius = callPackage ./genius {};
15 mtop = callPackage ./mtop {};
16 muttprint = callPackage ./muttprint {};
17 mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
18 nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
19 nagnu = callPackage ./nagnu { inherit mylibs; };
20 nb = callPackage ./nb {};
21 note = callPackage ./note {};
22 notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
23 notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
24 notmuch-vim = callPackage ./notmuch/notmuch-vim {};
25 openarc = (mylibs.flakeCompat ../flakes/openarc).default;
26 opendmarc = (mylibs.flakeCompat ../flakes/opendmarc).default;
27 pg_activity = callPackage ./pg_activity { inherit mylibs; };
28 pgloader = callPackage ./pgloader {};
29 predixy = callPackage ./predixy { inherit mylibs; };
30 rrsync_sudo = callPackage ./rrsync_sudo {};
31 signald = callPackage ./signald {};
32 signaldctl = callPackage ./signaldctl {};
33 telegram-cli = callPackage ./telegram-cli { inherit mylibs; };
34 telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
35 telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
36 terminal-velocity = callPackage ./terminal-velocity {};
37 tiv = callPackage ./tiv {};
38 twins = callPackage ./twins {};
39 unicodeDoc = callPackage ./unicode {};
40
41 cardano = callPackage ./crypto/cardano { inherit mylibs; };
42 cardano-cli = callPackage ./crypto/cardano-cli {};
43 iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
44 sia = callPackage ./crypto/sia {};
45
46 pure-ftpd = callPackage ./pure-ftpd {};
47 mpd = (callPackage ./mpd_0_21 {}).mpd;
48 mpd-small = (callPackage ./mpd_0_21 {}).mpd-small;
49
50 bitlbee-mastodon = callPackage ./bitlbee-mastodon {};
51
52 composerEnv = callPackage ./composer-env {};
53 webapps = callPackage ./webapps { inherit mylibs composerEnv; };
54
55 monitoring-plugins = callPackage ./monitoring-plugins {};
56 naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
57 naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
58 gearmand = callPackage ./gearmand {};
59 status_engine = {
60 module = callPackage ./status_engine/module.nix { inherit mylibs; };
61 worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
62 interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
63 };
64
65 python3PackagesPlus = callPackage ./python-packages {
66 python = python3;
67 inherit mylibs;
68 };
69 dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
70 inherit mylibs;
71 };
72 dovecot_fts-xapian = callPackage ./dovecot/plugins/fts_xapian {
73 inherit mylibs;
74 };
75
76 fiche = callPackage ./fiche { inherit mylibs; };
77 zrepl = callPackage ./zrepl {};
78 }