]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - nixops/modules/websites/tools/tools/roundcubemail.nix
38066794adc368c1d50a914a63d98860a94fb142
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / roundcubemail.nix
1 { lib, env, writeText, stdenv, fetchurl, fetchedGithub, phpPackages, apacheHttpd }:
2 let
3 roundcubemail = let
4 defaultInstall = ''
5 mkdir -p $out
6 cp -R . $out/
7 cd $out
8 if [ -d skins -a -d skins/larry -a ! -d skins/elastic ]; then
9 ln -s larry skins/elastic
10 fi
11 '';
12 buildPlugin = { appName, version, url, sha256, installPhase ? defaultInstall }:
13 stdenv.mkDerivation rec {
14 name = "roundcube-${appName}-${version}";
15 inherit version;
16 phases = "unpackPhase installPhase";
17 inherit installPhase;
18 src = fetchurl { inherit url sha256; };
19 };
20 plugins = {
21 carddav = buildPlugin rec {
22 appName = "carddav";
23 version = "3.0.3";
24 url = "https://github.com/blind-coder/rcmcarddav/releases/download/v${version}/${appName}-${version}.tar.bz2";
25 sha256 = "0cf5rnqkhhag2vdy808zfpr4l5586fn43nvcia8ac1ha58azrxal";
26 };
27 contextmenu = buildPlugin rec {
28 appName = "contextmenu";
29 version = "2.3";
30 url = "https://github.com/johndoh/roundcube-${appName}/archive/${version}.tar.gz";
31 sha256 = "1rb8n821ylfniiiccfskc534vd6rczhk3g82455ks3m09q6l8hif";
32 };
33 contextmenu_folder = buildPlugin rec {
34 appName = "contextmenu_folder";
35 version = "1.3.3";
36 url = "https://github.com/random-cuber/${appName}/archive/${version}.tar.gz";
37 sha256 = "1ngfws1v8qrpa52rjh7kirc98alchk2vbqwra86h00agyjjlcc57";
38 };
39 automatic_addressbook = buildPlugin rec {
40 appName = "automatic_addressbook";
41 version = "0.4.3";
42 url = "https://github.com/sblaisot/${appName}/archive/${version}.tar.gz";
43 sha256 = "0bx5qjzp3a3wc72fr295bvgsy5n15949c041hq76n6c7sqdn7inc";
44 };
45 message_highlight = buildPlugin rec {
46 appName = "message_highlight";
47 version = "4.4";
48 url = "https://github.com/corbosman/${appName}/archive/${version}.tar.gz";
49 sha256 = "12c4x47y70xdl5pgm8csh5i4yiyhpi232lvjbixmca6di4lkhh9j";
50 };
51 thunderbird_labels = buildPlugin rec {
52 appName = "thunderbird_labels";
53 version = "v1.3.2";
54 url = "https://github.com/mike-kfed/roundcube-${appName}/archive/${version}.tar.gz";
55 sha256 = "1q4x30w66m02v3lw2n8020g0158rmyfzs6gydfk89pa1hs28k9bg";
56 };
57 html5_notifier = buildPlugin rec {
58 appName = "html5_notifier";
59 version = "v0.6.2";
60 url = "https://github.com/stremlau/${appName}/archive/${version}.tar.gz";
61 sha256 = "0s1wq9ira4bcd8jvhn93nhxiqzpp92i0za2kw37kf7ksyhr0xslq";
62 };
63 ident_switch = buildPlugin rec {
64 appName = "ident_switch";
65 version = "4.0.1";
66 url = "https://bitbucket.org/BoresExpress/${appName}/get/${version}.tar.gz";
67 sha256 = "1zyy40lfq2kn7hkghbl8lgp18fb634zr4fxmmxvb1wqyvqdpdpyk";
68 };
69 };
70 skins = {};
71 in rec {
72 varDir = "/var/lib/roundcubemail";
73 activationScript = {
74 deps = [ "wrappers" ];
75 text = ''
76 install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir} \
77 ${varDir}/cache ${varDir}/logs
78 install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
79 '';
80 };
81 keys.tools-roundcube = {
82 destDir = "/run/keys/webapps";
83 user = apache.user;
84 group = apache.group;
85 permissions = "0700";
86 text = ''
87 <?php
88 $config['db_dsnw'] = '${env.psql_url}';
89 $config['default_host'] = 'ssl://mail.immae.eu';
90 $config['imap_conn_options'] = array("ssl" => array("verify_peer" => false));
91 $config['smtp_server'] = 'tls://mail.immae.eu';
92 $config['smtp_port'] = '25';
93 $config['managesieve_host'] = 'mail.immae.eu';
94 $config['managesieve_port'] = '4190';
95 $config['managesieve_usetls'] = true;
96 $config['managesieve_conn_options'] = array("ssl" => array("verify_peer" => false));
97
98 $config['imap_cache'] = 'db';
99 $config['messages_cache'] = 'db';
100
101 $config['support_url'] = ''';
102
103 $config['des_key'] = '${env.secret}';
104
105 $config['skin'] = 'elastic';
106 $config['plugins'] = array(
107 'attachment_reminder',
108 'emoticons',
109 'filesystem_attachments',
110 'hide_blockquote',
111 'identicon',
112 'identity_select',
113 'jqueryui',
114 'managesieve',
115 'newmail_notifier',
116 'vcard_attachments',
117 'zipdownload',
118
119 'automatic_addressbook',
120 'message_highlight',
121 'carddav',
122 // Ne marche pas ?: 'ident_switch',
123 // Ne marche pas ?: 'thunderbird_labels',
124 );
125
126 $config['language'] = 'fr_FR';
127
128 $config['drafts_mbox'] = 'Mail/Drafts';
129 $config['junk_mbox'] = 'Mail/Spam';
130 $config['sent_mbox'] = 'Mail/sent';
131 $config['trash_mbox'] = ''';
132 $config['default_folders'] = array('INBOX', 'Mail/Drafts', 'Mail/sent', 'Mail/Spam', ''');
133 $config['draft_autosave'] = 60;
134 $config['enable_installer'] = false;
135 $config['log_driver'] = 'file';
136 $config['temp_dir'] = '${varDir}/cache';
137 $config['mime_types'] = '${apacheHttpd}/conf/mime.types';
138 '';
139 };
140 webRoot = stdenv.mkDerivation rec {
141 version = "1.4-rc1";
142 name = "roundcubemail-${version}";
143 src= fetchurl {
144 url = "https://github.com/roundcube/roundcubemail/releases/download/${version}/${name}-complete.tar.gz";
145 sha256 = "0p18wffwi2prh6vxhx1bc69qd1vwybggm8gvg3shahfdknxci9i4";
146 };
147 buildPhase = ''
148 sed -i \
149 -e "s|RCUBE_INSTALL_PATH . 'temp.*|'${varDir}/cache';|" \
150 config/defaults.inc.php
151 sed -i \
152 -e "s|RCUBE_INSTALL_PATH . 'logs.*|'${varDir}/logs';|" \
153 config/defaults.inc.php
154 '';
155 installPhase = ''
156 cp -a . $out
157 ln -s /run/keys/webapps/tools-roundcube $out/config/config.inc.php
158 ${builtins.concatStringsSep "\n" (
159 lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/plugins/${name}") plugins
160 )}
161 ${builtins.concatStringsSep "\n" (
162 lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/skins/${name}") skins
163 )}
164 '';
165 };
166 apache = rec {
167 user = "wwwrun";
168 group = "wwwrun";
169 modules = [ "proxy_fcgi" ];
170 webappName = "tools_roundcubemail";
171 root = "/run/current-system/webapps/${webappName}";
172 vhostConf = ''
173 Alias /roundcube "${root}"
174 <Directory "${root}">
175 DirectoryIndex index.php
176 AllowOverride All
177 Options FollowSymlinks
178 Require all granted
179
180 <FilesMatch "\.php$">
181 SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"
182 </FilesMatch>
183 </Directory>
184 '';
185 };
186 phpFpm = rec {
187 serviceDeps = [ "postgresql.service" "tools-roundcube-key.service" ];
188 basedir = builtins.concatStringsSep ":" (
189 [ webRoot "/run/keys/webapps/tools-roundcube" varDir ]
190 ++ lib.attrsets.mapAttrsToList (name: value: value) plugins
191 ++ lib.attrsets.mapAttrsToList (name: value: value) skins);
192 phpConfig = ''
193 date.timezone = 'CET'
194 extension=${phpPackages.imagick}/lib/php/extensions/imagick.so
195 '';
196 socket = "/var/run/phpfpm/roundcubemail.sock";
197 pool = ''
198 listen = ${socket}
199 user = ${apache.user}
200 group = ${apache.group}
201 listen.owner = ${apache.user}
202 listen.group = ${apache.group}
203 pm = ondemand
204 pm.max_children = 60
205 pm.process_idle_timeout = 60
206
207 ; Needed to avoid clashes in browser cookies (same domain)
208 php_value[session.name] = RoundcubemailPHPSESSID
209 php_admin_value[upload_max_filesize] = 200M
210 php_admin_value[post_max_size] = 200M
211 php_admin_value[open_basedir] = "${basedir}:${apacheHttpd}/conf/mime.types:/tmp"
212 php_admin_value[session.save_path] = "${varDir}/phpSessions"
213 '';
214 };
215 };
216 in
217 roundcubemail