]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - nixops/modules/websites/tools/mastodon/mastodon.nix
3ee355227770a017c8d86a5f7be29aed7a9e6f22
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / mastodon.nix
1 { env, ruby_2_6, bundlerEnv, defaultGemConfig, yarn2nixPackage, fetchedGithub, stdenv, writeText, pkgs }:
2 let
3 varDir = "/var/lib/mastodon_immae";
4 socketsDir = "/run/mastodon";
5 gems = bundlerEnv {
6 name = "mastodon-env";
7 ruby = ruby_2_6;
8 gemset = ./gemset.nix;
9 gemdir = (fetchedGithub ./mastodon.json).src;
10 groups = [ "default" "production" "test" "development" ];
11 gemConfig = defaultGemConfig // {
12 redis-rack = attrs: {
13 preBuild = ''
14 sed -i 's!s\.files.*!!' redis-rack.gemspec
15 '';
16 };
17 tzinfo = attrs: {
18 preBuild = ''
19 sed -i 's!s\.files.*!!' tzinfo.gemspec
20 '';
21 };
22 cld3 = attrs: {
23 buildInputs = with pkgs; [ protobuf protobufc pkgconfig ];
24 };
25 idn-ruby = attrs: {
26 buildInputs = with pkgs; [ libidn ];
27 };
28 rpam2 = attrs: {
29 buildInputs = with pkgs; [ pam ];
30 };
31 };
32 };
33 yarnModules = let
34 info = fetchedGithub ./mastodon.json;
35 packagejson = pkgs.runCommand "package.json" { buildInputs = [ pkgs.jq ]; } ''
36 cat ${info.src}/package.json | jq -r '.version = "${info.version}"' > $out
37 '';
38 in
39 yarn2nixPackage.mkYarnModules rec {
40 name = "mastodon-yarn";
41 pname = name;
42 version = info.version;
43 packageJSON = packagejson;
44 yarnLock = "${info.src}/yarn.lock";
45 yarnNix = ./yarn-packages.nix;
46 pkgConfig = {
47 uws = {
48 postInstall = ''
49 npx node-gyp rebuild > build_log.txt 2>&1 || true
50 '';
51 };
52 };
53 };
54 mastodon = stdenv.mkDerivation (fetchedGithub ./mastodon.json // rec {
55 installPhase = ''
56 cp -a . $out
57 cp -a ${yarnModules}/node_modules $out
58 '';
59 buildInputs = [ yarnModules ];
60 });
61 keys.mastodon = {
62 dest = "webapps/tools-mastodon";
63 user = "mastodon";
64 group = "mastodon";
65 permissions = "0400";
66 text = ''
67 REDIS_HOST=${env.redis.host}
68 REDIS_PORT=${env.redis.port}
69 REDIS_DB=${env.redis.db}
70 DB_HOST=${env.postgresql.socket}
71 DB_USER=${env.postgresql.user}
72 DB_NAME=${env.postgresql.database}
73 DB_PASS=${env.postgresql.password}
74 DB_PORT=${env.postgresql.port}
75
76 LOCAL_DOMAIN=mastodon.immae.eu
77 LOCAL_HTTPS=true
78 ALTERNATE_DOMAINS=immae.eu
79
80 PAPERCLIP_SECRET=${env.paperclip_secret}
81 SECRET_KEY_BASE=${env.secret_key_base}
82 OTP_SECRET=${env.otp_secret}
83
84 VAPID_PRIVATE_KEY=${env.vapid.private}
85 VAPID_PUBLIC_KEY=${env.vapid.public}
86
87 SMTP_DELIVERY_METHOD=sendmail
88 SMTP_FROM_ADDRESS=mastodon@tools.immae.eu
89 SENDMAIL_LOCATION="/run/wrappers/bin/sendmail"
90 PAPERCLIP_ROOT_PATH=${varDir}
91
92 STREAMING_CLUSTER_NUM=1
93
94 RAILS_LOG_LEVEL=warn
95
96 # LDAP authentication (optional)
97 LDAP_ENABLED=true
98 LDAP_HOST=ldap.immae.eu
99 LDAP_PORT=636
100 LDAP_METHOD=simple_tls
101 LDAP_BASE="dc=immae,dc=eu"
102 LDAP_BIND_DN="cn=mastodon,ou=services,dc=immae,dc=eu"
103 LDAP_PASSWORD="${env.ldap.password}"
104 LDAP_UID="uid"
105 LDAP_SEARCH_FILTER="(&(%{uid}=%{email})(memberOf=cn=users,cn=mastodon,ou=services,dc=immae,dc=eu))"
106 '';
107 };
108
109 # FIXME: build machine will contain some passwords in the nix store
110 railsRoot = stdenv.mkDerivation {
111 name = "mastodon_immae";
112 inherit mastodon;
113 builder = writeText "build_mastodon_immae" ''
114 source $stdenv/setup
115 set -a
116 ${keys.mastodon.text}
117 set +a
118 cp -a $mastodon $out
119 cd $out
120 chmod u+rwX . public
121 chmod -R u+rwX config/
122 sed -i -e 's@^end$@ config.action_mailer.sendmail_settings = { location: ENV.fetch("SENDMAIL_LOCATION", "/usr/sbin/sendmail") }\nend@' config/environments/production.rb
123 RAILS_ENV=production ${gems}/bin/rails assets:precompile
124 rm -rf tmp/cache
125 ln -sf ${varDir}/tmp/cache tmp
126 '';
127 buildInputs = [ gems gems.ruby pkgs.nodejs pkgs.yarn ];
128 };
129 in
130 {
131 inherit railsRoot varDir socketsDir gems;
132 keys = builtins.attrValues keys;
133 nodeSocket = "${socketsDir}/live_immae_node.sock";
134 railsSocket = "${socketsDir}/live_immae_puma.sock";
135 }