]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - nixops/modules/websites/default.nix
9befdd166e3175d574448d0dd68538fbd81cb94d
[perso/Immae/Config/Nix.git] / nixops / modules / websites / default.nix
1 { lib, pkgs, config, mylibs, myconfig, ... }:
2 let
3 cfg = config.services.myWebsites;
4 makeService = name: cfg: let
5 toVhost = vhostConf: {
6 enableSSL = true;
7 sslServerCert = "/var/lib/acme/${vhostConf.certName}/cert.pem";
8 sslServerKey = "/var/lib/acme/${vhostConf.certName}/key.pem";
9 sslServerChain = "/var/lib/acme/${vhostConf.certName}/fullchain.pem";
10 logFormat = "combinedVhost";
11 listen = [
12 { ip = cfg.ip; port = 443; }
13 ];
14 hostName = builtins.head vhostConf.hosts;
15 serverAliases = builtins.tail vhostConf.hosts or [];
16 documentRoot = vhostConf.root;
17 extraConfig = builtins.concatStringsSep "\n" vhostConf.extraConfig;
18 };
19 redirectVhost = { # Should go last, catchall http -> https redirect
20 listen = [ { ip = cfg.ip; port = 80; } ];
21 hostName = "redirectSSL";
22 serverAliases = [ "*" ];
23 enableSSL = false;
24 logFormat = "combinedVhost";
25 documentRoot = "/var/lib/acme/acme-challenge";
26 extraConfig = ''
27 RewriteEngine on
28 RewriteCond "%{REQUEST_URI}" "!^/\.well-known"
29 RewriteRule ^(.+) https://%{HTTP_HOST}$1 [R=301]
30 # To redirect in specific "VirtualHost *:80", do
31 # RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://host/$1
32 # rather than rewrite
33 '';
34 };
35 fallbackVhost = toVhost { # Should go first, default choice
36 certName = "eldiron";
37 hosts = ["eldiron.immae.eu" ];
38 root = ../../www;
39 extraConfig = [ "DirectoryIndex index.htm" ];
40 };
41 in rec {
42 enable = true;
43 listen = [
44 { ip = cfg.ip; port = 443; }
45 ];
46 stateDir = "/run/httpd_${name}";
47 logPerVirtualHost = true;
48 multiProcessingModule = "worker";
49 adminAddr = "httpd@immae.eu";
50 logFormat = "combinedVhost";
51 extraModules = pkgs.lib.lists.unique (pkgs.lib.lists.flatten cfg.modules);
52 extraConfig = builtins.concatStringsSep "\n" cfg.extraConfig;
53 virtualHosts = [ fallbackVhost ]
54 ++ (pkgs.lib.attrsets.mapAttrsToList (n: v: toVhost v) cfg.vhostConfs)
55 ++ [ redirectVhost ];
56 };
57 makeServiceOptions = name: ip: {
58 enable = lib.mkEnableOption "enable websites in ${name}";
59 ip = lib.mkOption {
60 type = lib.types.string;
61 default = ip;
62 description = "${name} ip to listen to";
63 };
64 modules = lib.mkOption {
65 type = lib.types.listOf (lib.types.str);
66 default = [];
67 };
68 extraConfig = lib.mkOption {
69 type = lib.types.listOf (lib.types.lines);
70 default = [];
71 };
72 vhostConfs = lib.mkOption {
73 type = lib.types.attrsOf (lib.types.submodule {
74 options = {
75 certName = lib.mkOption { type = lib.types.string; };
76 hosts = lib.mkOption { type = lib.types.listOf lib.types.string; };
77 root = lib.mkOption { type = lib.types.nullOr lib.types.path; };
78 extraConfig = lib.mkOption { type = lib.types.listOf lib.types.lines; default = []; };
79 };
80 });
81 };
82 };
83 makeModules = cfg: pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
84 makeExtraConfig = cfg: (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
85 in
86 {
87 imports = [
88 ./chloe
89 ./ludivine
90 ./aten
91 ./piedsjaloux
92 ./connexionswing
93 ./tellesflorian
94 ./ftp/jerome.nix
95 ./tools/db
96 ./tools/tools
97 ./tools/dav
98 ./tools/cloud
99 ./tools/git
100 ./tools/mastodon
101 ./tools/mediagoblin
102 ./tools/diaspora
103 ./tools/ether
104 # built using:
105 # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
106 # Removed allGranted
107 # And removed users / groups
108 ./apache/httpd_prod.nix
109 ./apache/httpd_inte.nix
110 # except for this one for users/groups
111 ./apache/httpd_tools.nix
112 # Adapted from base phpfpm
113 ./phpfpm
114 ];
115
116 options.services.myWebsites = {
117 production = makeServiceOptions "production" myconfig.ips.production;
118 integration = makeServiceOptions "integration" myconfig.ips.integration;
119 tools = makeServiceOptions "tools" myconfig.ips.main;
120
121 apacheConfig = lib.mkOption {
122 type = lib.types.attrsOf (lib.types.submodule {
123 options = {
124 modules = lib.mkOption {
125 type = lib.types.listOf (lib.types.str);
126 default = [];
127 };
128 extraConfig = lib.mkOption {
129 type = lib.types.nullOr lib.types.lines;
130 default = null;
131 };
132 };
133 });
134 default = {};
135 description = "Extra global config";
136 };
137
138 };
139
140 config = {
141 networking = {
142 firewall = {
143 enable = true;
144 allowedTCPPorts = [ 80 443 ];
145 };
146 interfaces."eth0".ipv4.addresses = [
147 # 176.9.151.89 declared in nixops -> infra / tools
148 { address = myconfig.ips.production; prefixLength = 32; }
149 { address = myconfig.ips.integration; prefixLength = 32; }
150 ];
151 };
152
153 nixpkgs.config.packageOverrides = oldpkgs: rec {
154 php = php72;
155 php72 = (oldpkgs.php72.override {
156 mysql.connector-c = pkgs.mariadb;
157 config.php.mysqlnd = false;
158 config.php.mysqli = false;
159 }).overrideAttrs(old: rec {
160 # Didn't manage to build with mysqli + mysql_config connector
161 configureFlags = old.configureFlags ++ [
162 "--with-mysqli=shared,mysqlnd"
163 ];
164 # preConfigure = (old.preConfigure or "") + ''
165 # export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
166 # sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
167 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
168 # '';
169 });
170 phpPackages = oldpkgs.php72Packages.override { inherit php; };
171 composerEnv = import ./commons/composer-env.nix {
172 inherit (pkgs) stdenv writeTextFile fetchurl php unzip;
173 };
174 };
175
176 services.myWebsites.tools.databases.enable = true;
177 services.myWebsites.tools.tools.enable = true;
178 services.myWebsites.tools.dav.enable = true;
179 services.myWebsites.tools.cloud.enable = true;
180 services.myWebsites.tools.git.enable = true;
181 services.myWebsites.tools.mastodon.enable = true;
182 services.myWebsites.tools.mediagoblin.enable = true;
183 services.myWebsites.tools.diaspora.enable = true;
184 services.myWebsites.tools.etherpad-lite.enable = true;
185
186 services.myWebsites.Chloe.production.enable = cfg.production.enable;
187 services.myWebsites.Ludivine.production.enable = cfg.production.enable;
188 services.myWebsites.Aten.production.enable = cfg.production.enable;
189 services.myWebsites.PiedsJaloux.production.enable = cfg.production.enable;
190 services.myWebsites.Connexionswing.production.enable = cfg.production.enable;
191 services.myWebsites.Jerome.production.enable = cfg.production.enable;
192
193 services.myWebsites.Chloe.integration.enable = cfg.integration.enable;
194 services.myWebsites.Ludivine.integration.enable = cfg.integration.enable;
195 services.myWebsites.Aten.integration.enable = cfg.integration.enable;
196 services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
197 services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
198 services.myWebsites.TellesFlorian.integration.enable = true;
199
200 services.myWebsites.apacheConfig = {
201 gzip = {
202 modules = [ "deflate" "filter" ];
203 extraConfig = ''
204 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
205 '';
206 };
207 macros = {
208 modules = [ "macro" ];
209 };
210 ldap = {
211 modules = [ "ldap" "authnz_ldap" ];
212 extraConfig = ''
213 <IfModule ldap_module>
214 LDAPSharedCacheSize 500000
215 LDAPCacheEntries 1024
216 LDAPCacheTTL 600
217 LDAPOpCacheEntries 1024
218 LDAPOpCacheTTL 600
219 </IfModule>
220
221 <Macro LDAPConnect>
222 <IfModule authnz_ldap_module>
223 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
224 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
225 AuthLDAPBindPassword "${myconfig.env.httpd.ldap.password}"
226 AuthType Basic
227 AuthName "Authentification requise (Acces LDAP)"
228 AuthBasicProvider ldap
229 </IfModule>
230 </Macro>
231
232 <Macro Stats %{domain}>
233 Alias /awstats /var/lib/goaccess/%{domain}
234 <Directory /var/lib/goaccess/%{domain}>
235 DirectoryIndex index.html
236 AllowOverride None
237 Require all granted
238 </Directory>
239 <Location /awstats>
240 Use LDAPConnect
241 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
242 </Location>
243 </Macro>
244
245 ErrorDocument 500 /maintenance_immae.html
246 ErrorDocument 501 /maintenance_immae.html
247 ErrorDocument 502 /maintenance_immae.html
248 ErrorDocument 503 /maintenance_immae.html
249 ErrorDocument 504 /maintenance_immae.html
250 Alias /maintenance_immae.html ${../../www}/maintenance_immae.html
251 ProxyPass /maintenance_immae.html !
252
253 AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${../../www}/googleb6d69446ff4ca3e5.html
254 '';
255 };
256 http2 = {
257 modules = [ "http2" ];
258 extraConfig = ''
259 Protocols h2 http/1.1
260 '';
261 };
262 customLog = {
263 extraConfig = ''
264 LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
265 '';
266 };
267 };
268
269 system.activationScripts = {
270 httpd = ''
271 install -d -m 0755 /var/lib/acme/acme-challenge
272 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
273 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/adminer
274 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/mantisbt
275 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/davical
276 '';
277 };
278
279 services.myPhpfpm = {
280 phpPackage = pkgs.php;
281 phpOptions = ''
282 session.save_path = "/var/lib/php/sessions"
283 session.gc_maxlifetime = 60*60*24*15
284 session.cache_expire = 60*24*30
285 '';
286 extraConfig = ''
287 log_level = notice
288 '';
289 };
290
291 services.httpdProd = makeService "production" config.services.myWebsites.production;
292 services.myWebsites.production.modules = makeModules cfg;
293 services.myWebsites.production.extraConfig = makeExtraConfig cfg;
294
295 services.httpdInte = makeService "integration" config.services.myWebsites.integration;
296 services.myWebsites.integration.modules = makeModules cfg;
297 services.myWebsites.integration.extraConfig = makeExtraConfig cfg;
298
299 services.httpdTools = makeService "tools" config.services.myWebsites.tools;
300 services.myWebsites.tools.modules = makeModules cfg;
301 services.myWebsites.tools.extraConfig = makeExtraConfig cfg ++
302 [ ''
303 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
304 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
305 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
306 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
307 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
308 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
309 ''
310 ]
311 ;
312 };
313 }