]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - nixops/modules/websites/chloe/default.nix
a542d70f8e15d5585b5edaf40191527f74857d8b
[perso/Immae/Config/Nix.git] / nixops / modules / websites / chloe / default.nix
1 { lib, pkgs, config, myconfig, mylibs, ... }:
2 let
3 chloe = pkgs.callPackage ./chloe.nix { inherit (mylibs) fetchedGitPrivate; };
4 chloe_dev = chloe {
5 config = myconfig.env.websites.chloe.integration;
6 };
7 chloe_prod = chloe {
8 config = myconfig.env.websites.chloe.production;
9 };
10
11 cfg = config.services.myWebsites.Chloe;
12 in {
13 options.services.myWebsites.Chloe = {
14 production = {
15 enable = lib.mkEnableOption "enable Chloe's website in production";
16 };
17 integration = {
18 enable = lib.mkEnableOption "enable Chloe's website in integration";
19 };
20 };
21
22 config = lib.mkMerge [
23 (lib.mkIf cfg.production.enable {
24 secrets.keys = chloe_prod.keys;
25 services.webstats.sites = [ { name = "osteopathe-cc.fr"; } ];
26
27 security.acme.certs."chloe" = config.services.myCertificates.certConfig // {
28 domain = "osteopathe-cc.fr";
29 extraDomains = {
30 "www.osteopathe-cc.fr" = null;
31 };
32 };
33
34 services.myPhpfpm.serviceDependencies.chloe_prod = chloe_prod.phpFpm.serviceDeps;
35 services.myPhpfpm.poolConfigs.chloe_prod = chloe_prod.phpFpm.pool;
36 services.myPhpfpm.poolPhpConfigs.chloe_prod = ''
37 extension=${pkgs.php}/lib/php/extensions/mysqli.so
38 '';
39 system.activationScripts.chloe_prod = chloe_prod.activationScript;
40 system.extraSystemBuilderCmds = ''
41 mkdir -p $out/webapps
42 ln -s ${chloe_prod.webRoot} $out/webapps/${chloe_prod.apache.webappName}
43 '';
44 services.myWebsites.production.modules = chloe_prod.apache.modules;
45 services.myWebsites.production.vhostConfs.chloe = {
46 certName = "chloe";
47 hosts = ["osteopathe-cc.fr" "www.osteopathe-cc.fr" ];
48 root = chloe_prod.apache.root;
49 extraConfig = [ chloe_prod.apache.vhostConf ];
50 };
51 })
52 (lib.mkIf cfg.integration.enable {
53 secrets.keys = chloe_dev.keys;
54 security.acme.certs."eldiron".extraDomains."chloe.immae.eu" = null;
55 services.myPhpfpm.serviceDependencies.chloe_dev = chloe_dev.phpFpm.serviceDeps;
56 services.myPhpfpm.poolConfigs.chloe_dev = chloe_dev.phpFpm.pool;
57 services.myPhpfpm.poolPhpConfigs.chloe_dev = ''
58 extension=${pkgs.php}/lib/php/extensions/mysqli.so
59 '';
60 system.activationScripts.chloe_dev = chloe_dev.activationScript;
61 system.extraSystemBuilderCmds = ''
62 mkdir -p $out/webapps
63 ln -s ${chloe_dev.webRoot} $out/webapps/${chloe_dev.apache.webappName}
64 '';
65 services.myWebsites.integration.modules = chloe_dev.apache.modules;
66 services.myWebsites.integration.vhostConfs.chloe = {
67 certName = "eldiron";
68 hosts = ["chloe.immae.eu" ];
69 root = chloe_dev.apache.root;
70 extraConfig = [ chloe_dev.apache.vhostConf ];
71 };
72 })
73 ];
74 }