]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/websites/papa/maison_bbc.nix
3eb736ee1b80b515f77a213a7ff7aa3aa70c726f
[perso/Immae/Config/Nix.git] / modules / private / websites / papa / maison_bbc.nix
1 { lib, config, ... }:
2 let
3 cfg = config.myServices.websites.papa.maison_bbc;
4 in {
5 options.myServices.websites.papa.maison_bbc.enable = lib.mkEnableOption "enable Papa Maison bbc website";
6
7 config = lib.mkIf cfg.enable {
8 services.webstats.sites = [ { name = "maison.bbc.bouya.org"; } ];
9
10 services.websites.env.production.vhostConfs.papa_maison_bbc = {
11 certName = "papa";
12 addToCerts = true;
13 hosts = [ "maison.bbc.bouya.org" ];
14 root = ./maison_bbc_static;
15 extraConfig = [
16 ''
17 ErrorDocument 404 /index.html
18 <Directory ${./maison_bbc_static}>
19 DirectoryIndex index.htm index.html
20 AllowOverride None
21 Require all granted
22 </Directory>
23 ''
24 ];
25 };
26 };
27 }
28