]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/websites/chloe/integration.nix
6276eb7bf1a236a8c51b37220505eab001440361
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / integration.nix
1 { lib, pkgs, config, ... }:
2 let
3 chloe = pkgs.callPackage ./builder.nix {
4 inherit (pkgs.webapps) chloe;
5 config = config.myEnv.websites.chloe.integration;
6 apacheUser = config.services.httpd.Inte.user;
7 apacheGroup = config.services.httpd.Inte.group;
8 };
9
10 cfg = config.myServices.websites.chloe.integration;
11 in {
12 options.myServices.websites.chloe.integration.enable = lib.mkEnableOption "enable Chloe's website in integration";
13
14 config = lib.mkIf cfg.enable {
15 services.duplyBackup.profiles.chloe_dev.rootDir = chloe.app.varDir;
16 secrets.keys = chloe.keys;
17 systemd.services.phpfpm-chloe_dev.after = lib.mkAfter chloe.phpFpm.serviceDeps;
18 systemd.services.phpfpm-chloe_dev.wants = chloe.phpFpm.serviceDeps;
19 services.phpfpm.pools.chloe_dev = {
20 listen = chloe.phpFpm.socket;
21 extraConfig = chloe.phpFpm.pool;
22 phpOptions = config.services.phpfpm.phpOptions + ''
23 extension=${pkgs.php}/lib/php/extensions/mysqli.so
24 '';
25 };
26 system.activationScripts.chloe_dev = chloe.activationScript;
27 myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
28 services.websites.env.integration.modules = chloe.apache.modules;
29 services.websites.env.integration.vhostConfs.chloe = {
30 certName = "integration";
31 addToCerts = true;
32 hosts = ["chloe.immae.eu" ];
33 root = chloe.apache.root;
34 extraConfig = [ chloe.apache.vhostConf ];
35 };
36 services.websites.env.integration.watchPaths = [
37 "/var/secrets/webapps/${chloe.app.environment}-chloe"
38 ];
39 };
40 }