]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/system/backup-2.nix
1d84667de9ba6d794abc28f4be5dda23f0b32c0a
[perso/Immae/Config/Nix.git] / modules / private / system / backup-2.nix
1 { privateFiles }:
2 { config, pkgs, resources, ... }:
3 {
4 boot.kernelPackages = pkgs.linuxPackages_latest;
5 myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
6
7 imports = builtins.attrValues (import ../..);
8
9 deployment = {
10 targetEnv = "hetznerCloud";
11 hetznerCloud = {
12 authToken = config.myEnv.hetznerCloud.authToken;
13 datacenter = "hel1-dc2";
14 location ="hel1";
15 serverType = "cx11";
16 };
17 };
18
19 fileSystems = {
20 "/backup2" = {
21 fsType = "ext4";
22 device = "UUID=b9425333-f567-435d-94d8-b26c22d93426";
23 };
24 };
25
26 networking = {
27 firewall.enable = true;
28 interfaces."ens3".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
29 (n: ips: { address = ips.ip4; prefixLength = 32; })
30 (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips);
31 interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
32 (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
33 config.hostEnv.ips);
34 defaultGateway6 = { address = "fe80::1"; interface = "ens3"; };
35 };
36
37 myServices.certificates.enable = true;
38 services.nginx = {
39 enable = true;
40 recommendedOptimisation = true;
41 recommendedGzipSettings = true;
42 recommendedProxySettings = true;
43 };
44 networking.firewall.allowedTCPPorts = [ 80 443 ];
45
46 services.cron = {
47 mailto = "cron@immae.eu";
48 enable = true;
49 };
50
51 services.rsyncBackup = {
52 mountpoint = "/backup2";
53 mailto = config.myEnv.rsync_backup.mailto;
54 profiles = config.myEnv.rsync_backup.profiles;
55 ssh_key_public = config.myEnv.rsync_backup.ssh_key.public;
56 ssh_key_private = config.myEnv.rsync_backup.ssh_key.private;
57 };
58
59 myServices.mailRelay.enable = true;
60 myServices.mailBackup.enable = true;
61 myServices.monitoring.enable = true;
62 myServices.databasesReplication = {
63 postgresql = {
64 enable = true;
65 base = "/backup2";
66 hosts = {
67 eldiron = {
68 slot = "backup_2";
69 connection = "postgresql://backup-2:${config.hostEnv.ldap.password}@eldiron.immae.eu";
70 };
71 };
72 };
73 mariadb = {
74 enable = true;
75 base = "/backup2";
76 hosts = {
77 eldiron = {
78 serverId = 2;
79 # mysql resolves "backup-2" host and checks the ip, but uses /etc/hosts which only contains ip4
80 host = config.myEnv.servers.eldiron.ips.main.ip4;
81 port = "3306";
82 user = "backup-2";
83 password = config.hostEnv.ldap.password;
84 dumpUser = "root";
85 dumpPassword = config.myEnv.databases.mysql.systemUsers.root;
86 };
87 };
88 };
89 redis = {
90 enable = true;
91 base = "/backup2";
92 hosts = {
93 eldiron = {
94 host = "127.0.0.1";
95 port = "16379";
96 };
97 };
98 };
99 openldap = {
100 enable = true;
101 base = "/backup2";
102 hosts = {
103 eldiron = {
104 url = "ldaps://${config.myEnv.ldap.host}:636";
105 dn = config.myEnv.ldap.replication_dn;
106 password = config.myEnv.ldap.replication_pw;
107 base = config.myEnv.ldap.base;
108 };
109 };
110 };
111 };
112
113 # This value determines the NixOS release with which your system is
114 # to be compatible, in order to avoid breaking some software such as
115 # database servers. You should change this only after NixOS release
116 # notes say you should.
117 # https://nixos.org/nixos/manual/release-notes.html
118 system.stateVersion = "19.03"; # Did you read the comment?
119 }