]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_monitoring-1.nix
fdee81140ecbfd6ae4157daf01da450f717c7ede
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_monitoring-1.nix
1 { config, pkgs, nodes, hostFQDN, emailCheck, lib, ... }:
2 let
3 to_backup_age_dependency = name: profile: map (remote:
4 {
5 dependent_host_name = "eldiron.immae.eu";
6 host_name = "eldiron.immae.eu";
7 dependent_service_description = "${remote} backup for ${name} is not too old";
8 service_description = "${remote} backup is up and not full";
9 execution_failure_criteria = "u";
10 notification_failure_criteria = "u";
11 }) profile.remotes;
12 to_backup_age = name: profile: map (remote:
13 {
14 service_description = "${remote} backup for ${name} is not too old";
15 host_name = "eldiron.immae.eu";
16 use = "external-service";
17 check_command = ["check_backup_${remote}_age" name];
18
19 check_interval = "120";
20 notification_interval = "1440";
21 }) profile.remotes;
22 in
23 {
24 host = {
25 # Dummy host for testing
26 # "dummy-host" = {
27 # alias = "dummy.host";
28 # address = "dummy.host";
29 # use = "linux-server";
30 # check_command = "check_ok";
31 # };
32 };
33 service = [
34 # Dummy service for testing
35 # {
36 # service_description = "Dummy failing test";
37 # host_name = "dummy-host";
38 # use = "local-service";
39 # check_interval = "0.3";
40 # max_check_attempts = "1";
41 # flap_detection_enabled = "0";
42 # notification_interval = "0.1";
43 # check_command = "check_critical";
44 # }
45
46 (emailCheck "monitoring-1" hostFQDN)
47
48 {
49 service_description = "ftp has access to database for authentication";
50 host_name = "eldiron.immae.eu";
51 use = "external-service";
52 check_command = "check_ftp_database";
53
54 servicegroups = "webstatus-remote-services";
55 _webstatus_name = "FTP";
56 _webstatus_url = "ftp.immae.eu";
57 }
58
59 {
60 service_description = "gitolite is working";
61 host_name = "eldiron.immae.eu";
62 use = "external-web-service";
63 check_command = "check_git";
64
65 servicegroups = "webstatus-remote-services";
66 _webstatus_name = "Git";
67 _webstatus_url = "git.immae.eu";
68 }
69
70 {
71 service_description = "postfix SSL is up to date";
72 host_name = "eldiron.immae.eu";
73 use = "external-service";
74 check_command = "check_smtp";
75
76 servicegroups = "webstatus-ssl";
77 _webstatus_name = "SMTP";
78 _webstatus_url = "smtp.immae.eu";
79 }
80
81 {
82 service_description = "imap SSL is up to date";
83 host_name = "eldiron.immae.eu";
84 use = "external-service";
85 check_command = ["check_tcp_ssl" "993"];
86
87 servicegroups = "webstatus-ssl";
88 _webstatus_name = "IMAP";
89 _webstatus_url = "imap.immae.eu";
90 }
91
92 {
93 service_description = "imap connection works";
94 host_name = "eldiron.immae.eu";
95 use = "external-service";
96 check_command = "check_imap_connection";
97
98 servicegroups = "webstatus-remote-services,webstatus-email";
99 _webstatus_name = "IMAP";
100 _webstatus_url = "imap.immae.eu";
101 }
102
103 # Third party services
104 {
105 service_description = "OVH account has enough sms";
106 host_name = "eldiron.immae.eu";
107 use = "external-service";
108 check_command = "check_ovh_sms";
109
110 check_interval = "120";
111 notification_interval = "1440";
112 }
113
114 # Backup services
115 {
116 service_description = "eriomem backup is up and not full";
117 host_name = "eldiron.immae.eu";
118 use = "external-service";
119 check_command = "check_backup_eriomem";
120
121 check_interval = "120";
122 notification_interval = "1440";
123
124 servicegroups = "webstatus-backup";
125 }
126 {
127 service_description = "ovh backup is up and not full";
128 host_name = "eldiron.immae.eu";
129 use = "external-service";
130 check_command = "check_ok";
131
132 check_interval = "120";
133 notification_interval = "1440";
134
135 servicegroups = "webstatus-backup";
136 }
137
138 # DNS services
139 {
140 service_description = "eldiron dns is active and authoritative for aten.pro";
141 host_name = "eldiron.immae.eu";
142 use = "dns-service";
143 check_command = ["check_dns" "aten.pro" "-A"];
144
145 servicegroups = "webstatus-dns";
146 _webstatus_name = "aten.pro";
147 }
148
149 {
150 service_description = "eldiron dns is active and authoritative for bouya.org";
151 host_name = "eldiron.immae.eu";
152 use = "dns-service";
153 check_command = ["check_dns" "bouya.org" "-A"];
154
155 servicegroups = "webstatus-dns";
156 _webstatus_name = "bouya.org";
157 }
158
159 {
160 service_description = "eldiron dns is active and authoritative for filedesreves.fr";
161 host_name = "eldiron.immae.eu";
162 use = "dns-service";
163 check_command = ["check_dns" "filedesreves.fr" "-A"];
164
165 servicegroups = "webstatus-dns";
166 _webstatus_name = "filedesreves.fr";
167 }
168
169 {
170 service_description = "eldiron dns is active and authoritative for ludivinecassal.com";
171 host_name = "eldiron.immae.eu";
172 use = "dns-service";
173 check_command = ["check_dns" "ludivinecassal.com" "-A"];
174
175 servicegroups = "webstatus-dns";
176 _webstatus_name = "ludivinecassal.com";
177 }
178
179 {
180 service_description = "eldiron dns is active and authoritative for icommandeur.org";
181 host_name = "eldiron.immae.eu";
182 use = "dns-service";
183 check_command = ["check_dns" "icommandeur.org" "-A"];
184
185 servicegroups = "webstatus-dns";
186 _webstatus_name = "icommandeur.org";
187 }
188
189 {
190 service_description = "eldiron dns is active and authoritative for immae.eu";
191 host_name = "eldiron.immae.eu";
192 use = "dns-service";
193 check_command = ["check_dns" "immae.eu" "-A"];
194
195 servicegroups = "webstatus-dns";
196 _webstatus_name = "immae.eu";
197 }
198
199 {
200 service_description = "eldiron dns is active and authoritative for immae.fr";
201 host_name = "eldiron.immae.eu";
202 use = "dns-service";
203 check_command = ["check_dns" "immae.fr" "-A"];
204
205 servicegroups = "webstatus-dns";
206 _webstatus_name = "immae.fr";
207 }
208
209 {
210 service_description = "eldiron dns is active and authoritative for piedsjaloux.fr";
211 host_name = "eldiron.immae.eu";
212 use = "dns-service";
213 check_command = ["check_dns" "piedsjaloux.fr" "-A"];
214
215 servicegroups = "webstatus-dns";
216 _webstatus_name = "piedsjaloux.fr";
217 }
218
219 {
220 service_description = "eldiron dns is active and authoritative for saison-photo.org";
221 host_name = "eldiron.immae.eu";
222 use = "dns-service";
223 check_command = ["check_dns" "saison-photo.org" "-A"];
224
225 servicegroups = "webstatus-dns";
226 _webstatus_name = "saison-photo.org";
227 }
228
229 {
230 service_description = "eldiron dns is active and authoritative for tellesflorian.com";
231 host_name = "eldiron.immae.eu";
232 use = "dns-service";
233 check_command = ["check_dns" "tellesflorian.com" "-A"];
234
235 servicegroups = "webstatus-dns";
236 _webstatus_name = "tellesflorian.com";
237 }
238
239 {
240 service_description = "eldiron dns is active and authoritative for capitaines.fr";
241 host_name = "eldiron.immae.eu";
242 use = "dns-service";
243 check_command = ["check_dns" "capitaines.fr" "-A"];
244
245 servicegroups = "webstatus-dns";
246 _webstatus_name = "capitaines.fr";
247 }
248
249 {
250 service_description = "cloudns dns is active and authoritative for aten.pro";
251 host_name = "eldiron.immae.eu";
252 use = "dns-service";
253 check_command = ["check_external_dns" "pns1.cloudns.net" "aten.pro" "-A"];
254
255 servicegroups = "webstatus-dns";
256 _webstatus_name = "aten.pro (Secondary DNS ClouDNS)";
257 }
258
259 {
260 service_description = "cloudns dns is active and authoritative for bouya.org";
261 host_name = "eldiron.immae.eu";
262 use = "dns-service";
263 check_command = ["check_external_dns" "pns1.cloudns.net" "bouya.org" "-A"];
264
265 servicegroups = "webstatus-dns";
266 _webstatus_name = "bouya.org (Secondary DNS ClouDNS)";
267 }
268
269 {
270 service_description = "cloudns dns is active and authoritative for filedesreves.fr";
271 host_name = "eldiron.immae.eu";
272 use = "dns-service";
273 check_command = ["check_external_dns" "pns1.cloudns.net" "filedesreves.fr" "-A"];
274
275 servicegroups = "webstatus-dns";
276 _webstatus_name = "filedesreves.fr (Secondary DNS ClouDNS)";
277 }
278
279 {
280 service_description = "cloudns dns is active and authoritative for ludivinecassal.com";
281 host_name = "eldiron.immae.eu";
282 use = "dns-service";
283 check_command = ["check_external_dns" "pns1.cloudns.net" "ludivinecassal.com" "-A"];
284
285 servicegroups = "webstatus-dns";
286 _webstatus_name = "ludivinecassal.com (Secondary DNS ClouDNS)";
287 }
288
289 {
290 service_description = "cloudns dns is active and authoritative for icommandeur.org";
291 host_name = "eldiron.immae.eu";
292 use = "dns-service";
293 check_command = ["check_external_dns" "pns1.cloudns.net" "icommandeur.org" "-A"];
294
295 servicegroups = "webstatus-dns";
296 _webstatus_name = "icommandeur.org (Secondary DNS ClouDNS)";
297 }
298
299 {
300 service_description = "cloudns dns is active and authoritative for immae.eu";
301 host_name = "eldiron.immae.eu";
302 use = "dns-service";
303 check_command = ["check_external_dns" "pns1.cloudns.net" "immae.eu" "-A"];
304
305 servicegroups = "webstatus-dns";
306 _webstatus_name = "immae.eu (Secondary DNS ClouDNS)";
307 }
308
309 {
310 service_description = "cloudns dns is active and authoritative for immae.fr";
311 host_name = "eldiron.immae.eu";
312 use = "dns-service";
313 check_command = ["check_external_dns" "pns1.cloudns.net" "immae.fr" "-A"];
314
315 servicegroups = "webstatus-dns";
316 _webstatus_name = "immae.fr (Secondary DNS ClouDNS)";
317 }
318
319 {
320 service_description = "cloudns dns is active and authoritative for piedsjaloux.fr";
321 host_name = "eldiron.immae.eu";
322 use = "dns-service";
323 check_command = ["check_external_dns" "pns1.cloudns.net" "piedsjaloux.fr" "-A"];
324
325 servicegroups = "webstatus-dns";
326 _webstatus_name = "piedsjaloux.fr (Secondary DNS ClouDNS)";
327 }
328
329 {
330 service_description = "cloudns dns is active and authoritative for tellesflorian.com";
331 host_name = "eldiron.immae.eu";
332 use = "dns-service";
333 check_command = ["check_external_dns" "pns1.cloudns.net" "tellesflorian.com" "-A"];
334
335 servicegroups = "webstatus-dns";
336 _webstatus_name = "tellesflorian.com (Secondary DNS ClouDNS)";
337 }
338
339 {
340 service_description = "cloudns dns is active and authoritative for saison-photo.org";
341 host_name = "eldiron.immae.eu";
342 use = "dns-service";
343 check_command = ["check_external_dns" "pns1.cloudns.net" "saison-photo.org" "-A"];
344
345 servicegroups = "webstatus-dns";
346 _webstatus_name = "saison-photo.org (Secondary DNS ClouDNS)";
347 }
348
349 #### Web scenarios
350 {
351 service_description = "blog website is running on immae.eu";
352 host_name = "eldiron.immae.eu";
353 use = "external-web-service";
354 check_command = ["check_https" "www.immae.eu" "/blog/" "egrep -ri TODO /etc"];
355
356 servicegroups = "webstatus-websites";
357 _webstatus_name = "Immae’s Blog";
358 _webstatus_url = "https://www.immae.eu/blog";
359 }
360
361 {
362 service_description = "owncloud website is running on cloud.immae.eu";
363 host_name = "eldiron.immae.eu";
364 use = "external-web-service";
365 check_command = ["check_https" "cloud.immae.eu" "/" "a safe home for all your data"];
366
367 servicegroups = "webstatus-webapps";
368 _webstatus_name = "Nextcloud";
369 _webstatus_url = "https://cloud.immae.eu";
370 }
371
372 {
373 service_description = "davical website is running on dav.immae.eu";
374 host_name = "eldiron.immae.eu";
375 use = "external-web-service";
376 check_command = ["check_https" "dav.immae.eu" "/davical/" "Log On Please"];
377
378 servicegroups = "webstatus-webapps";
379 _webstatus_name = "Davical";
380 _webstatus_url = "https://dav.immae.eu/davical";
381 }
382
383 {
384 service_description = "adminer website is running on tools.immae.eu";
385 host_name = "eldiron.immae.eu";
386 use = "external-web-service";
387 check_command = ["check_https_auth" "tools.immae.eu" "/adminer/" "www.adminer.org"];
388
389 servicegroups = "webstatus-webapps";
390 _webstatus_name = "Adminer";
391 _webstatus_url = "https://tools.immae.eu/adminer/";
392 }
393
394 {
395 service_description = "ttrss website is running on tools.immae.eu";
396 host_name = "eldiron.immae.eu";
397 use = "external-web-service";
398 check_command = ["check_https" "tools.immae.eu" "/ttrss/" "<title>Tiny Tiny RSS"];
399
400 servicegroups = "webstatus-webapps";
401 _webstatus_name = "TT-RSS";
402 _webstatus_url = "https://tools.immae.eu/ttrss/";
403 }
404
405 {
406 service_description = "mpd website is running on tools.immae.eu";
407 host_name = "eldiron.immae.eu";
408 use = "external-web-service";
409 check_command = ["check_https_auth" "tools.immae.eu" "/mpd/" "<title>ympd"];
410
411 servicegroups = "webstatus-webapps";
412 _webstatus_name = "MPD (YMPD)";
413 _webstatus_url = "https://tools.immae.eu/mpd/";
414 }
415
416 {
417 service_description = "rompr mpd website is running on tools.immae.eu";
418 host_name = "eldiron.immae.eu";
419 use = "external-web-service";
420 check_command = ["check_https_auth" "tools.immae.eu" "/rompr/" "<title>RompЯ"];
421
422 servicegroups = "webstatus-webapps";
423 _webstatus_name = "MPD (ROMPR)";
424 _webstatus_url = "https://tools.immae.eu/rompr/";
425 }
426
427 {
428 service_description = "wallabag website is running on tools.immae.eu";
429 host_name = "eldiron.immae.eu";
430 use = "external-web-service";
431 check_command = ["check_https" "tools.immae.eu" "/wallabag/" "<title>Bienvenue sur wallabag"];
432
433 servicegroups = "webstatus-webapps";
434 _webstatus_name = "Wallabag";
435 _webstatus_url = "https://tools.immae.eu/wallabag/";
436 }
437
438 {
439 service_description = "yourl website is running on tools.immae.eu";
440 host_name = "eldiron.immae.eu";
441 use = "external-web-service";
442 check_command = ["check_https" "tools.immae.eu" "/url/admin/" "<title>YOURLS"];
443
444 servicegroups = "webstatus-webapps";
445 _webstatus_name = "YOURLS";
446 _webstatus_url = "https://tools.immae.eu/url/admin/";
447 }
448
449 {
450 service_description = "roundcube website is running on mail.immae.eu";
451 host_name = "eldiron.immae.eu";
452 use = "external-web-service";
453 check_command = ["check_https" "mail.immae.eu" "/roundcube/" "<title>Roundcube"];
454
455 servicegroups = "webstatus-webapps,webstatus-email";
456 _webstatus_name = "Roundcube";
457 _webstatus_url = "https://mail.immae.eu/roundcube/";
458 }
459
460 {
461 service_description = "dokuwiki website is running on tools.immae.eu";
462 host_name = "eldiron.immae.eu";
463 use = "external-web-service";
464 check_command = ["check_https" "tools.immae.eu" "/dokuwiki/" "<title>start"];
465
466 servicegroups = "webstatus-webapps";
467 _webstatus_name = "Dokuwiki";
468 _webstatus_url = "https://tools.immae.eu/dokuwiki/";
469 }
470
471 {
472 service_description = "shaarli website is running on tools.immae.eu";
473 host_name = "eldiron.immae.eu";
474 use = "external-web-service";
475 check_command = ["check_https" "tools.immae.eu" "/Shaarli/immae" "<title>Immae"];
476
477 servicegroups = "webstatus-webapps";
478 _webstatus_name = "Shaarli";
479 _webstatus_url = "https://tools.immae.eu/Shaarli/";
480 }
481
482 {
483 service_description = "ldap website is running on tools.immae.eu";
484 host_name = "eldiron.immae.eu";
485 use = "external-web-service";
486 check_command = ["check_https" "tools.immae.eu" "/ldap/" "<title>phpLDAPadmin"];
487
488 servicegroups = "webstatus-webapps";
489 _webstatus_name = "LDAP";
490 _webstatus_url = "https://tools.immae.eu/ldap/";
491 }
492
493 {
494 service_description = "gitweb website is running on git.immae.eu";
495 host_name = "eldiron.immae.eu";
496 use = "external-web-service";
497 check_command = ["check_https" "git.immae.eu" "/" "git web interface"];
498
499 servicegroups = "webstatus-webapps";
500 _webstatus_name = "Git";
501 _webstatus_url = "https://git.immae.eu/";
502 }
503
504 {
505 service_description = "mantisbt website is running on git.immae.eu";
506 host_name = "eldiron.immae.eu";
507 use = "external-web-service";
508 check_command = ["check_https" "git.immae.eu" "/mantisbt/" "<title>My View - MantisBT"];
509
510 servicegroups = "webstatus-webapps";
511 _webstatus_name = "Mantisbt";
512 _webstatus_url = "https://git.immae.eu/mantisbt";
513 }
514
515 {
516 service_description = "diaspora website is running on diaspora.immae.eu";
517 host_name = "eldiron.immae.eu";
518 use = "external-web-service";
519 check_command = ["check_https" "diaspora.immae.eu" "/" "is the online social world where you are in control"];
520
521 servicegroups = "webstatus-webapps";
522 _webstatus_name = "Diaspora";
523 _webstatus_url = "https://diaspora.immae.eu/";
524 }
525
526 {
527 service_description = "peertube website is running on peertube.immae.eu";
528 host_name = "eldiron.immae.eu";
529 use = "external-web-service";
530 check_command = ["check_https" "peertube.immae.eu" "/" "<title>Immae’s PeerTube"];
531
532 servicegroups = "webstatus-webapps";
533 _webstatus_name = "Peertube";
534 _webstatus_url = "https://peertube.immae.eu/";
535 }
536
537 {
538 service_description = "etherpad website is running on ether.immae.eu";
539 host_name = "eldiron.immae.eu";
540 use = "external-web-service";
541 check_command = ["check_https" "ether.immae.eu" "/" "<title>Etherpad"];
542
543 servicegroups = "webstatus-webapps";
544 _webstatus_name = "Etherpad";
545 _webstatus_url = "https://ether.immae.eu/";
546 }
547
548 {
549 service_description = "mediagoblin website is running on mgoblin.immae.eu";
550 host_name = "eldiron.immae.eu";
551 use = "external-web-service";
552 check_command = ["check_https" "mgoblin.immae.eu" "/" "<title>GNU MediaGoblin"];
553
554 servicegroups = "webstatus-webapps";
555 _webstatus_name = "Mediagoblin";
556 _webstatus_url = "https://mgoblin.immae.eu/";
557 }
558
559 {
560 service_description = "mastodon website is running on mastodon.immae.eu";
561 host_name = "eldiron.immae.eu";
562 use = "external-web-service";
563 check_command = ["check_https" "mastodon.immae.eu" "/" "Mastodon</title>"];
564
565 servicegroups = "webstatus-webapps";
566 _webstatus_name = "Mastodon";
567 _webstatus_url = "https://mastodon.immae.eu/";
568 }
569
570 # Other web pages
571 {
572 service_description = "Jerome website is running on naturaloutil.immae.eu";
573 host_name = "eldiron.immae.eu";
574 use = "external-web-service";
575 check_command = ["check_https" "naturaloutil.immae.eu" "/ping.php" "YES"];
576
577 servicegroups = "webstatus-websites";
578 _webstatus_name = "naturaloutil.immae.eu";
579 _webstatus_url = "https://naturaloutil.immae.eu/";
580 }
581
582 {
583 service_description = "Telio website is running on realistesmedia.fr";
584 host_name = "eldiron.immae.eu";
585 use = "external-web-service";
586 check_command = ["check_https" "realistesmedia.fr" "/" "doctype html"];
587 contact_groups = "telio-tortay";
588 }
589
590 {
591 service_description = "Chloe website site is running on osteopathe-cc.fr";
592 host_name = "eldiron.immae.eu";
593 use = "external-web-service";
594 check_command = ["check_https" "www.osteopathe-cc.fr" "/" "<title>Chloé Condamin ostéopathe D.O."];
595
596 servicegroups = "webstatus-websites";
597 _webstatus_name = "osteopathe-cc.fr";
598 _webstatus_url = "https://www.osteopathe-cc.fr/";
599 }
600
601 {
602 service_description = "Richie website is running on europe-richie.org";
603 host_name = "eldiron.immae.eu";
604 use = "external-web-service";
605 check_command = ["check_https" "www.europe-richie.org" "/" "<title>.Europe Richie]"];
606
607 servicegroups = "webstatus-websites";
608 _webstatus_name = "europe-richie.org";
609 _webstatus_url = "https://www.europe-richie.org/";
610 }
611
612 {
613 service_description = "Ludivine website site is running on ludivinecassal.com";
614 host_name = "eldiron.immae.eu";
615 use = "external-web-service";
616 check_command = ["check_https" "www.ludivinecassal.com" "/" "<title>Ludivine Cassal"];
617
618 servicegroups = "webstatus-websites";
619 _webstatus_name = "ludivinecassal.com";
620 _webstatus_url = "https://www.ludivinecassal.com/";
621 }
622
623 {
624 service_description = "Aten website site is running on aten.pro";
625 host_name = "eldiron.immae.eu";
626 use = "external-web-service";
627 check_command = ["check_https" "aten.pro" "/" "<title>ATEN"];
628
629 servicegroups = "webstatus-websites";
630 _webstatus_name = "aten.pro";
631 _webstatus_url = "https://aten.pro/";
632 }
633
634 {
635 service_description = "PiedsJaloux website site is running on piedsjaloux.fr";
636 host_name = "eldiron.immae.eu";
637 use = "external-web-service";
638 check_command = ["check_https" "www.piedsjaloux.fr" "/" "<title>Les Pieds Jaloux"];
639
640 servicegroups = "webstatus-websites";
641 _webstatus_name = "piedsjaloux.fr";
642 _webstatus_url = "https://www.piedsjaloux.fr/";
643 }
644
645 {
646 service_description = "Denise and Jerome website site is running on denisejerome.piedsjaloux.fr";
647 host_name = "eldiron.immae.eu";
648 use = "external-web-service";
649 check_command = ["check_https" "denisejerome.piedsjaloux.fr" "/" "<title>Accueil - Mariage"];
650
651 servicegroups = "webstatus-websites";
652 _webstatus_name = "denisejerome.piedsjaloux.fr";
653 _webstatus_url = "https://denisejerome.piedsjaloux.fr/";
654 }
655
656 {
657 service_description = "Connexionswing website site is running on connexionswing.com";
658 host_name = "eldiron.immae.eu";
659 use = "external-web-service";
660 check_command = ["check_https" "www.connexionswing.com" "/" "<title>Cours, stages"];
661
662 servicegroups = "webstatus-websites";
663 _webstatus_name = "connexionswing.com";
664 _webstatus_url = "https://www.connexionswing.com/";
665 }
666
667 {
668 service_description = "Sandetludo website site is running on sandetludo.com";
669 host_name = "eldiron.immae.eu";
670 use = "external-web-service";
671 check_command = ["check_https" "www.sandetludo.com" "/" "<title>Cours de West Coast"];
672
673 servicegroups = "webstatus-websites";
674 _webstatus_name = "sandetludo.com";
675 _webstatus_url = "https://www.sandetludo.com/";
676 }
677
678 # SSL
679 {
680 service_description = "ldap SSL is up to date";
681 host_name = "eldiron.immae.eu";
682 use = "external-service";
683 check_command = ["check_tcp_ssl" "636"];
684
685 servicegroups = "webstatus-ssl";
686 _webstatus_name = "LDAP";
687 _webstatus_url = "ldap.immae.eu";
688 }
689
690 # Tiboqorl
691 {
692 service_description = "Cyllene support page is running";
693 host_name = "tiboqorl.fr";
694 use = "external-web-service";
695 contact_groups = "tiboqorl";
696 check_command = [ "check_https" "sc.groupe-cyllene.com" "/" "<title>Support Client Cyllene" ];
697 }
698 ] ++ lib.flatten (lib.mapAttrsToList to_backup_age nodes.eldiron.config.services.duplyBackup.profiles);
699 contact = {
700 telio-tortay = config.myEnv.monitoring.contacts.telio-tortay // {
701 use = "generic-contact";
702 contactgroups = "telio-tortay";
703 };
704 thibault = config.myEnv.monitoring.contacts.thibault // {
705 use = "generic-contact";
706 contactgroups = "tiboqorl";
707 };
708 };
709 contactgroup = {
710 telio-tortay = { alias = "Telio Tortay"; members = "immae"; };
711 tiboqorl = { alias = "Tiboqorl"; members = "immae"; };
712 };
713 servicedependency = lib.flatten (lib.mapAttrsToList to_backup_age_dependency nodes.eldiron.config.services.duplyBackup.profiles);
714 }