]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/databases/openldap/eldiron_schemas.nix
fc686dd9c7619e69dc131bc9c973543940a4b884
[perso/Immae/Config/Nix.git] / modules / private / databases / openldap / eldiron_schemas.nix
1 { fetchurl, openldap }:
2 let
3 kerberosSchema = fetchurl {
4 url = "https://raw.githubusercontent.com/krb5/krb5/0bdd3b8058ed4ec9acc050e316bea86f6830b15f/src/plugins/kdb/ldap/libkdb_ldap/kerberos.schema";
5 sha256 = "17fnkkf6s3lznsl7wp6914pqsc78d038rh38l638big8z608ksww";
6 };
7 puppetSchema = fetchurl {
8 url = "https://raw.githubusercontent.com/puppetlabs/puppet/bf7c108825ffdb5ea89cf3e500d55d27ab64b8d2/ext/ldap/puppet.schema";
9 sha256 = "11bjf5zfvqlim7p9vddcafs0wiq3v8ys77x8h6fbp9c6bdfh0awh";
10 };
11 schemas = [
12 "${openldap}/etc/schema/core.schema"
13 "${openldap}/etc/schema/cosine.schema"
14 "${openldap}/etc/schema/inetorgperson.schema"
15 "${openldap}/etc/schema/nis.schema"
16 puppetSchema
17 kerberosSchema
18 ./immae.schema
19 ];
20 in
21 builtins.concatStringsSep "\n" (map (v: "include ${v}") schemas)