]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - virtual/packages/connexionswing.nix
Replace unstable with stable in environment
[perso/Immae/Config/Nix.git] / virtual / packages / connexionswing.nix
CommitLineData
5c101474 1{ lib, checkEnv, writeText, fetchedGitPrivate, stdenv, php, git, cacert }:
940f1834
IB
2let
3 connexionswing = { environment ? "dev" }: rec {
4 varDir = "/var/lib/connexionswing_${environment}";
5 envName= lib.strings.toUpper environment;
6 configRoot =
7 # FIXME: spool emails in prod for when immae.eu is down?
8 assert checkEnv "NIXOPS_CONNEXIONSWING_${envName}_MYSQL_PASSWORD";
9 assert checkEnv "NIXOPS_CONNEXIONSWING_${envName}_MYSQL_USER";
10 assert checkEnv "NIXOPS_CONNEXIONSWING_${envName}_MYSQL_NAME";
11 assert checkEnv "NIXOPS_CONNEXIONSWING_${envName}_SECRET";
12 assert checkEnv "NIXOPS_CONNEXIONSWING_${envName}_EMAIL";
5c101474 13 writeText "parameters.yml" ''
940f1834
IB
14 # This file is auto-generated during the composer install
15 parameters:
16 database_host: db-1.immae.eu
17 database_port: null
18 database_name: ${builtins.getEnv "NIXOPS_CONNEXIONSWING_${envName}_MYSQL_NAME"}
19 database_user: ${builtins.getEnv "NIXOPS_CONNEXIONSWING_${envName}_MYSQL_USER"}
20 database_password: ${builtins.getEnv "NIXOPS_CONNEXIONSWING_${envName}_MYSQL_PASSWORD"}
21 mailer_transport: smtp
22 mailer_host: mail.immae.eu
23 mailer_user: null
24 mailer_password: null
25 subscription_email: ${builtins.getEnv "NIXOPS_CONNEXIONSWING_${envName}_EMAIL"}
26 allow_robots: true
27 secret: ${builtins.getEnv "NIXOPS_CONNEXIONSWING_${envName}_SECRET"}
28 '';
29 phpFpm = rec {
30 socket = "/var/run/phpfpm/connexionswing-${environment}.sock";
31 pool = ''
32 listen = ${socket}
33 user = ${apache.user}
34 group = ${apache.group}
35 listen.owner = ${apache.user}
36 listen.group = ${apache.group}
37 php_admin_value[upload_max_filesize] = 20M
38 php_admin_value[post_max_size] = 20M
39 ;php_admin_flag[log_errors] = on
40 php_admin_value[open_basedir] = "${configRoot}:${webappDir}:${varDir}:/tmp"
41 ${if environment == "dev" then ''
42 pm = ondemand
43 pm.max_children = 5
44 pm.process_idle_timeout = 60
45 env[SYMFONY_DEBUG_MODE] = "yes"
46 '' else ''
47 pm = dynamic
48 pm.max_children = 20
49 pm.start_servers = 2
50 pm.min_spare_servers = 1
51 pm.max_spare_servers = 3
52 ''}'';
53 };
54 apache = {
55 user = "wwwrun";
56 group = "wwwrun";
57 modules = [ "proxy_fcgi" ];
58 vhostConf = ''
59 <FilesMatch "\.php$">
60 SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"
61 </FilesMatch>
62
63 <Directory ${varDir}/medias>
64 Options FollowSymLinks
65 AllowOverride None
66 Require all granted
67 </Directory>
68
69 <Directory ${varDir}/uploads>
70 Options FollowSymLinks
71 AllowOverride None
72 Require all granted
73 </Directory>
74
75 ${if environment == "dev" then ''
76 <Location />
77 Use LDAPConnect
78 Require ldap-group cn=connexionswing.immae.eu,cn=httpd,ou=services,dc=immae,dc=eu
79 ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://connexionswing.com\"></html>"
80 </Location>
81
82 <Directory ${webRoot}>
83 Options Indexes FollowSymLinks MultiViews Includes
84 AllowOverride None
85 Require all granted
86
87 DirectoryIndex app_dev.php
88
89 <IfModule mod_negotiation.c>
90 Options -MultiViews
91 </IfModule>
92
93 <IfModule mod_rewrite.c>
94 RewriteEngine On
95
96 RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
97 RewriteRule ^(.*) - [E=BASE:%1]
98
99 # Maintenance script
100 RewriteCond %{DOCUMENT_ROOT}/maintenance.php -f
101 RewriteCond %{SCRIPT_FILENAME} !maintenance.php
102 RewriteRule ^.*$ %{ENV:BASE}/maintenance.php [R=503,L]
103 ErrorDocument 503 /maintenance.php
104
105 # Sets the HTTP_AUTHORIZATION header removed by Apache
106 RewriteCond %{HTTP:Authorization} .
107 RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
108
109 RewriteCond %{ENV:REDIRECT_STATUS} ^$
110 RewriteRule ^app_dev\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]
111
112 # If the requested filename exists, simply serve it.
113 # We only want to let Apache serve files and not directories.
114 RewriteCond %{REQUEST_FILENAME} -f
115 RewriteRule ^ - [L]
116
117 # Rewrite all other queries to the front controller.
118 RewriteRule ^ %{ENV:BASE}/app_dev.php [L]
119 </IfModule>
120
121 </Directory>
122 '' else ""}
123 '';
124 };
125 activationScript = {
126 deps = [ "wrappers" ];
127 text = ''
128 install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir} \
129 ${varDir}/medias \
130 ${varDir}/uploads \
131 ${varDir}/var
132 if [ ! -f "${varDir}/currentWebappDir" -o \
133 "${webappDir}" != "$(cat ${varDir}/currentWebappDir 2>/dev/null)" ]; then
134 pushd ${webappDir} > /dev/null
135 $wrapperDir/sudo -u wwwrun ./bin/console --env=${environment} cache:clear --no-warmup
136 popd > /dev/null
137 echo -n "${webappDir}" > ${varDir}/currentWebappDir
138 fi
139 '';
140 };
5c101474 141 webappDir = stdenv.mkDerivation (fetchedGitPrivate ./connexionswing_master.json // rec {
940f1834
IB
142 # FIXME: can we do better than symlink?
143 # FIXME: imagick optional
144 # FIXME: initial sync
145 # FIXME: backup
9f944a58 146 # FIXME: replace with pkgs.phpPackages.composer
940f1834 147 buildPhase = ''
5c101474
IB
148 export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
149 export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
940f1834
IB
150
151 ln -sf ../../../../../${varDir}/{medias,uploads} web/images/
152 ln -sf ${configRoot} app/config/parameters.yml
153 ${if environment == "dev" then "php bin/composer install" else ''
154 SYMFONY_ENV=prod php bin/composer install --no-dev
155 ./bin/console assetic:dump --env=prod --no-debug
156 ''}
157 rm -rf var
158 ln -sf ../../../../../${varDir}/var var
159 '';
160 installPhase = ''
161 cp -a . $out
162 '';
163 buildInputs = [
5c101474 164 php git cacert
940f1834
IB
165 ];
166 });
167 webRoot = "${webappDir}/web";
168 };
5c101474 169in
940f1834 170 connexionswing