]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - virtual/modules/websites/aten/aten.nix
Fix deprecation for networking addresses in hetzner
[perso/Immae/Config/Nix.git] / virtual / modules / websites / aten / aten.nix
CommitLineData
6c672f34
IB
1{ lib, checkEnv, writeText, fetchedGitPrivate, stdenv, php, git, cacert, phpPackages, yarn }:
2let
3 aten = { environment ? "dev" }: rec {
4 varPrefix = "ATEN";
5 varDir = "/var/lib/aten_${environment}";
6 envName= lib.strings.toUpper environment;
7 phpFpm = rec {
8 socket = "/var/run/phpfpm/aten-${environment}.sock";
9 pool = ''
10 listen = ${socket}
11 user = ${apache.user}
12 group = ${apache.group}
13 listen.owner = ${apache.user}
14 listen.group = ${apache.group}
15 php_admin_value[upload_max_filesize] = 20M
16 php_admin_value[post_max_size] = 20M
17 ;php_admin_flag[log_errors] = on
18 php_admin_value[open_basedir] = "${webappDir}:${varDir}:/tmp"
c8e019b6 19 php_admin_value[session.save_path] = "${varDir}/phpSessions"
6c672f34
IB
20 ${if environment == "dev" then ''
21 pm = ondemand
22 pm.max_children = 5
23 pm.process_idle_timeout = 60
24 env[SYMFONY_DEBUG_MODE] = "yes"
25 '' else ''
26 pm = dynamic
27 pm.max_children = 20
28 pm.start_servers = 2
29 pm.min_spare_servers = 1
30 pm.max_spare_servers = 3
31 ''}'';
32 };
33 apache = {
34 user = "wwwrun";
35 group = "wwwrun";
36 modules = [ "proxy_fcgi" ];
37 vhostConf =
38 assert checkEnv "NIXOPS_${varPrefix}_${envName}_SECRET";
39 assert checkEnv "NIXOPS_${varPrefix}_${envName}_PSQL_URL";
40 ''
41 <FilesMatch "\.php$">
42 SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"
43 </FilesMatch>
44
45 SetEnv APP_ENV "${environment}"
46 SetEnv APP_SECRET "${builtins.getEnv "NIXOPS_${varPrefix}_${envName}_SECRET"}
47 SetEnv DATABASE_URL "${builtins.getEnv "NIXOPS_${varPrefix}_${envName}_PSQL_URL"}
48
49 ${if environment == "dev" then ''
50 <Location />
51 Use LDAPConnect
52 Require ldap-group cn=dev.aten.pro,cn=httpd,ou=services,dc=immae,dc=eu
53 ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://aten.pro\"></html>"
54 </Location>
55
56 <Location /backend>
57 Use LDAPConnect
58 Require ldap-group cn=dev.aten.pro,cn=httpd,ou=services,dc=immae,dc=eu
59 ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://aten.pro\"></html>"
60 </Location>
61 '' else ''
34e2fd14
IB
62 Use Stats aten.pro
63
6c672f34
IB
64 <Location /backend>
65 Use LDAPConnect
66 Require ldap-group cn=aten.pro,cn=httpd,ou=services,dc=immae,dc=eu
67 ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://aten.pro\"></html>"
68 </Location>
69 ''}
70
71 <Directory ${webRoot}>
72 Options Indexes FollowSymLinks MultiViews Includes
73 AllowOverride All
74 Require all granted
75 DirectoryIndex index.php
76 FallbackResource /index.php
77 </Directory>
78 '';
79 };
80 activationScript = {
81 deps = [ "wrappers" ];
82 text = ''
83 install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir}
c8e019b6 84 install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
6c672f34
IB
85 if [ ! -f "${varDir}/currentWebappDir" -o \
86 "${webappDir}" != "$(cat ${varDir}/currentWebappDir 2>/dev/null)" ]; then
87 pushd ${webappDir} > /dev/null
88 $wrapperDir/sudo -u wwwrun APP_ENV=${environment} ./bin/console --env=${environment} cache:clear --no-warmup
89 popd > /dev/null
90 echo -n "${webappDir}" > ${varDir}/currentWebappDir
91 fi
92 '';
93 };
94 webappDir = stdenv.mkDerivation (fetchedGitPrivate ./aten.json // rec {
6c672f34
IB
95 buildPhase = ''
96 export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
97 export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
98 export APP_ENV="${environment}"
99 export DATABASE_URL="${builtins.getEnv "NIXOPS_${varPrefix}_${envName}_PSQL_URL"}"
100 export APP_SECRET="${builtins.getEnv "NIXOPS_${varPrefix}_${envName}_SECRET"}"
101
102 ${if environment == "dev" then ''
103 composer install
104 '' else ''
105 SYMFONY_ENV=prod composer install --no-dev
106 ''}
107 yarn install
108 yarn run encore production
109 rm -rf var
110 ln -sf ../../../../../${varDir} var
111 '';
112 installPhase = ''
113 cp -a . $out
114 '';
115 buildInputs = [
116 php git cacert phpPackages.composer yarn
117 ];
118 });
119 webRoot = "${webappDir}/public";
120 };
121in
122 aten