]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - systems/eldiron/websites/vpn/default.nix
Add tinc configuration
[perso/Immae/Config/Nix.git] / systems / eldiron / websites / vpn / default.nix
CommitLineData
ea9c6fe8
IB
1{ lib, pkgs, config, ... }:
2let
3 cfg = config.myServices.vpn;
4in {
5 config = lib.mkIf cfg.enable {
1a64deeb 6 security.acme.certs.eldiron.extraDomainNames = [ "vpn.immae.eu" ];
ea9c6fe8
IB
7 services.websites.env.tools.vhostConfs.vpn = {
8 certName = "eldiron";
ea9c6fe8 9 hosts = [ "vpn.immae.eu" ];
750fe5a4 10 root = ./www;
450e0db1
IB
11 extraConfig = [
12 ''
13 Alias /hosts.tar.gz "${config.myServices.vpn.hostsPath}"
14 ''
15 ];
ea9c6fe8 16 };
ea9c6fe8
IB
17 };
18}