]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - shell.nix
Add snapshot date check for monitoring
[perso/Immae/Config/Nix.git] / shell.nix
CommitLineData
0c506c05
IB
1{ pkgs ? import <nixpkgs> { overlays = builtins.attrValues (import ./overlays); },
2 pkgs-nix ? import <nixpkgs-nix> { overlays = builtins.attrValues (import ./overlays); }
3}:
4let
5 patchedNix = pkgs-nix.nixUnstable.overrideAttrs(old: {
6 patches = old.patches ++ [
7 # Fix the ETag bug. PR merged. Remove when updating to >= 20210125
8 # https://github.com/NixOS/nixpkgs/pull/109309#issuecomment-768331750
9 (pkgs-nix.fetchpatch {
10 url = "https://patch-diff.githubusercontent.com/raw/NixOS/nix/pull/4470.diff";
11 sha256 = "sha256-d4RNOKMxa4NMbFgYcqWRv2ByHt8F/XUWV+6P9qHz7S4=";
12 })
13 ];
14 });
15in
da28a4e2 16pkgs.mkShell {
0c506c05 17 buildInputs = [ patchedNix pkgs.morph pkgs.niv pkgs.pass pkgs.curl pkgs.shellcheck pkgs.jq pkgs.gnumake ];
da28a4e2 18}