]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/modules/mail/default.nix
Add users for redis and nullmailer
[perso/Immae/Config/Nix.git] / nixops / modules / mail / default.nix
CommitLineData
af421a8f
IB
1{ lib, pkgs, config, myconfig, mylibs, ... }:
2{
52c3e9e7
IB
3 config.ids.uids.nullmailer = myconfig.env.users.nullmailer.uid;
4 config.ids.gids.nullmailer = myconfig.env.users.nullmailer.gid;
5 config.users.users.nullmailer.uid = config.ids.uids.nullmailer;
6 config.users.groups.nullmailer.gid = config.ids.gids.nullmailer;
7
af421a8f
IB
8 config.services.nullmailer = {
9 enable = true;
10 config = {
11 me = myconfig.env.mail.host;
12 remotes = "${myconfig.env.mail.relay} smtp";
13 };
14 };
15}