]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/tools/vpn/default.nix
Refactor websites
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / vpn / default.nix
CommitLineData
ea9c6fe8
IB
1{ lib, pkgs, config, ... }:
2let
3 cfg = config.myServices.vpn;
4in {
5 config = lib.mkIf cfg.enable {
6 services.websites.env.tools.vhostConfs.vpn = {
7 certName = "eldiron";
8 addToCerts = true;
9 hosts = [ "vpn.immae.eu" ];
10 root = "/run/current-system/webapps/_vpn";
11 };
12
d3452fc5 13 services.websites.webappDirs._vpn = ./www;
ea9c6fe8
IB
14 };
15}