]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/tools/tools/landing.nix
Use personnal project for landing page
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / landing.nix
CommitLineData
67cc3b92
IB
1{ sources, stdenv, yarn2nix-moretea }:
2let
3 yarnModules = yarn2nix-moretea.mkYarnModules rec {
4 name = "landing";
5 pname = name;
6 version = "v1.0.0";
7 packageJSON = "${sources.webapps-landing}/package.json";
8 yarnLock = "${sources.webapps-landing}/yarn.lock";
9 yarnNix = ./landing/yarn-packages.nix;
251c0a13 10 };
67cc3b92
IB
11in
12 stdenv.mkDerivation rec {
13 pname = "landing";
14 version = "v1.0.0";
15 src = sources.webapps-landing;
251c0a13 16
67cc3b92
IB
17 buildInputs = [ yarnModules yarn2nix-moretea.yarn ];
18 configurePhase = ''
19 ln -s ${yarnModules}/node_modules .
20 '';
21 buildPhase = ''
22 yarn build
23 '';
24 installPhase = ''
25 cp -a dist $out
26 cp ${./landing}/*.php $out/
27 ln -s service-worker.js $out/worker.js
28 '';
29 }